"Clear your recent history" and "Remove individual cookies" opens up a new tab to http:///#

VERIFIED FIXED in Firefox 50

Status

()

Firefox
Preferences
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Jia Yuan Lo, Assigned: Gijs)

Tracking

({regression})

50 Branch
Firefox 50
regression
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, firefox50 verified)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160627030215

Steps to reproduce:

1. Go to about:preferences#privacy
2. Left click "Clear your recent history" or "Remove individual cookies"
3. A dialog appeared is ok but a new tab opens up with weird URL not...

Does it got to do with this href="#"?

<label xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul" class="text-link" id="historyRememberClear" href="#">clear your recent history</label>

<label xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul" class="text-link" id="historyRememberCookies" href="#" style="transition: transform 1s ease 0s;">remove individual cookies</label>


Actual results:

A new tab opens up with URL http:///#


Expected results:

No new tab should appear...

Updated

2 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Preferences
Ever confirmed: true
this is a regression from bug 1280472.
Blocks: 1280472
Keywords: regression

Updated

2 years ago
status-firefox49: --- → unaffected
status-firefox50: --- → affected

Updated

2 years ago
Duplicate of this bug: 1283031

Comment 4

2 years ago
backoutbugherder
https://hg.mozilla.org/mozilla-central/rev/4aeee4260fcd
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Duplicate of this bug: 1283429
Works again in 20160630030207.
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1283127
Assignee: nobody → gijskruitbosch+bugs
QA Whiteboard: [good first verify]

Comment 8

2 years ago
On my platform it works just fine. im running firefox version 50.0 beta 7

On windows 7 - 64 bits
in Firefox beta 50.07 works better, i am using windows 7 64bits
(Assignee)

Updated

2 years ago
Status: RESOLVED → VERIFIED
status-firefox50: fixed → verified
You need to log in before you can comment on or make changes to this bug.