Bug 1282893 (webext-port-adblock-pro)

Enable Adblock Pro extension to work with Firefox

RESOLVED DUPLICATE of bug 1309926

Status

()

Toolkit
WebExtensions: Compatibility
P5
normal
RESOLVED DUPLICATE of bug 1309926
a year ago
4 months ago

People

(Reporter: mattw, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [popular chrome extensions]triaged)

(Reporter)

Description

a year ago
Chrome store link: https://chrome.google.com/webstore/detail/adblock-pro/ocifcklkibdehekfnmflempfgjhbedch

Manifest Errors:
- Error processing incognito: Invalid enumeration value "split"
- Unknown permission "unlimitedStorage"
- Error processing update_url
- Error processing author
- Error processing minimum_chrome_version
- Error processing options_page
- Error processing optional_permissions
- Error processing storage
    "storage": {
        "managed_schema": "managed_storage.json"
    }
(Reporter)

Comment 1

a year ago
grepping the source code for chrome.storage reveals the following missing APIs:

- chrome.storage.managed
- chrome.storage.sync.QUOTA_BYTES_PER_ITEM
- chrome.storage.sync.QUOTA_BYTES
- chrome.storage.sync.get
- chrome.storage.sync.remove
- chrome.storage.sync.set
(Reporter)

Updated

a year ago
Depends on: 1220494

Updated

8 months ago
Component: WebExtensions: Untriaged → WebExtensions: Compatibility
Priority: -- → P5

Updated

4 months ago
Depends on: 1230802

Comment 2

4 months ago
Adblock Pro is just a rip-off of uBlock Origin by the way, see <http://www.ghacks.net/2016/12/18/chromes-adblock-pro-is-a-ublock-origin-rip-off/>.

So anyways yes, I was testing the webext version of uBlock Origin, and it's missing chrome.storage.sync.QUOTA_BYTES_PER_ITEM and chrome.storage.sync.QUOTA_BYTES. I could assume some safe values meanwhile, any suggestions for what these safe values should be are welcomed.
In that case, I think we can dupe this to enabling uBlock Origin.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309926
You need to log in before you can comment on or make changes to this bug.