Freeze when reentering page with several applets

RESOLVED WORKSFORME

Status

Core Graveyard
Java: OJI
--
major
RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: Ole Dalgaard, Assigned: Joshua Xia)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.0.3 (X11; Linux i686; U;) Gecko/0
BuildID:    20020204

Freeze when reentering page with several applets

Reproducible: Always
Steps to Reproduce:
1. Goto the page http://www.giraffen.dk/javatest/
2. Press the 'AA' button
3. use the 'Back' button (now mozilla and java freezes)
4. ...

Actual Results:  mozilla and java freezes

kill -9 `/sbin/pidof java_vm
is necessary

Expected Results:  Show the applets again

Using JDK 1.4.0-final  ns610/libjavaplugin_oji140.so plugin

Comment 1

16 years ago
No hang here with 2002022808 on Win2k / JRE 1.4.0
But it is slow.   (approx 30 seconds on a PIII-900 w/ 256MB RAM)

Comment 2

16 years ago
freeze on load here. Win-2k, Mozilla build 2002032003
JavaPlugin: JRE 1.3.1_02

Seems like some recent versions of the plugin/JRE don't like the fphover applet
and presumably other applets written to 1.0/1.1 API's.

Comment 3

16 years ago
Confirming. Redhat 6.2 with jre1.4.0beta3
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
This is reproducible for me on linux (debian) on ppc, with build 2002032923,
also w/9.9).  I'm using Blackdown-1.3.1-02a-FCS jdk.
This seems to be a special case of #141825.
There it is shown that the bug doesn't depend on the applet at all.

Updated

15 years ago
QA Contact: pmac → petersen
(Assignee)

Comment 6

15 years ago
reassign to me
Assignee: joe.chou → joshua.xia

Comment 7

15 years ago
WFM on windows2000/Linux(RH8.0) mozilla1.2 JRE1.4.1_01
Closing. See also bug 141825 which changed summary because the bug appearance
changed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.