All users were logged out of Bugzilla on October 13th, 2018

Solaris applet resizing isn't working.

VERIFIED DUPLICATE of bug 131065

Status

()

VERIFIED DUPLICATE of bug 131065
17 years ago
16 years ago

People

(Reporter: csmith, Assigned: serhunt)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    2002020516

Solaris applet resizing isn't working.

If you use percentage values for an applet (e.g. 100%, 100%), when you resize 
the window the applet remains the initial size. 

This behavior only appears to be occurring in the Solaris version of the 
browser. It does not occur on Windows versions (the applet sizes to fit the new 
browser size). I haven't checked the Linux build, but from other bug reports, 
it appears that it may be working.

I have attached a simple test case that reproduces the problem.

Reproducible: Always
Steps to Reproduce:
1. Create an applet and give it percentage width and height values (e.g. 100%, 
100%)
2. Resize the browser.

Actual Results:  The applet remains the initial size, it doesn't resize to fit 
the new window dimensions.

Expected Results:  The applet would resize to fit the new window dimensions.

Please see the attached test case.
(Reporter)

Comment 1

17 years ago
Created attachment 71912 [details]
Simple applet that draws a rectangle indicating the current applet size

Comment 2

17 years ago
cc'ing sujay since he has a solaris box and might be able to take a look at this.

anthonyd

Comment 3

17 years ago
Confirmed that the attached applet does not re-size with Sparc Solaris build
2002051322.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
paint() is not called everytime when resize browser.

Comment 5

17 years ago
cannot view the attached testcase, it is coming across as a .exe file. Reporter,
can you please reattach the test case, but please give it another mimetype
besides application/octet-stream. Maybe attach an html file and reference the
applet within the html file.

Comment 6

17 years ago
ah, this is a dup (% sizing)

*** This bug has been marked as a duplicate of 131065 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.