If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The loading bar is not dismissed after tapping on the tab

VERIFIED FIXED

Status

()

Firefox for iOS
General
VERIFIED FIXED
a year ago
11 months ago

People

(Reporter: SimonB, Unassigned)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios6.0+, fxios-v5.0 affected, fxios-v6.0 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Build: 5.0(8) Nightly
Device: iPad Air 2

Steps to reproduce:
1. Go to google.com in private browsing
2. While the page is loading tap on the tab

Actual result:
- The loading bar will be displayed after the page has been loaded. Also the loading bar will be displayed after following step 1) and tapping on the tab

Expected:
- The loading bar should be hidden after the page has been loaded

See URL for more information: https://youtu.be/s6KIa2lCf3o
(Reporter)

Updated

a year ago
Blocks: 1278667
(Reporter)

Updated

a year ago
Summary: The loading bar will be displayed when tapping on the tab → The loading bar is not dismissed after tapping on the tab
Created attachment 8766351 [details] [review]
https://github.com/mozilla/firefox-ios/pull/1965
Attachment #8766351 - Flags: review?(sleroux)
Comment on attachment 8766351 [details] [review]
https://github.com/mozilla/firefox-ios/pull/1965

Works well. Annoying that this seemingly random boolean effects the loading bar.
Attachment #8766351 - Flags: review?(sleroux) → review+
master 0de93bd9d05c9b47c6bd2530eeef9038d5526d29
Status: NEW → RESOLVED
Last Resolved: a year ago
status-fxios-v6.0: --- → fixed
Resolution: --- → FIXED
tracking-fxios: ? → 6.0+

Updated

a year ago
Duplicate of this bug: 1284606
(Reporter)

Comment 5

11 months ago
Tested on iPad Air 2 (10.0.2).

Verifying as fix on master 0e03028ac. The loading bar is displayed and dismissed correctly after the page has been loaded.
Status: RESOLVED → VERIFIED
status-fxios-v6.0: fixed → verified
You need to log in before you can comment on or make changes to this bug.