Closed Bug 1283392 Opened 4 years ago Closed 1 year ago

Query for history or comment containing private bug id should return no data for this bug

Categories

(bugzilla.mozilla.org :: API, defect, P2)

Production
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: calixte, Assigned: kohei.yoshino)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review
curl "https://bugzilla.mozilla.org/rest/bug/123457/history?ids=123456" => error
curl "https://bugzilla.mozilla.org/rest/bug?id=123456&id=123457" => ok: no data for bug 123456

In the first case, only history of bug 123457 should be returned.
Yea that's a known issue affecting BzDeck as well ;)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1169040
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: webservice → nobody
Status: REOPENED → NEW
Component: WebService → API
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Version: unspecified → Production
Assignee: nobody → kohei.yoshino
Priority: -- → P1

This is the same issue as Bug 1169040.

See Also: → 1169040
Status: NEW → ASSIGNED
Attached file GitHub Pull Request

Adjusting the priority since a workaround has been in place in libmozdata.

I’m adding the new skip_private param to both the history and comment APIs while retaining the current throwing behaviour, otherwise CircleCI tests will fail. This will no longer throw once this change is deployed:

https://bugzilla.mozilla.org/rest/bug/123457/history?ids=123456&skip_private=1

Priority: P1 → P2

The same problem applies to attachments too.

Merged to master. I missed Marco’s comment; will file a new bug for that.

Status: ASSIGNED → RESOLVED
Closed: 4 years ago1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.