WebRTC video from build-in camera is broken(blank)

RESOLVED INCOMPLETE

Status

()

Firefox for Android
Audio/Video
RESOLVED INCOMPLETE
2 years ago
2 years ago

People

(Reporter: Alex Caziuc, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox50 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8766725 [details]
webrtc.png

Tested with:
Device: HTC Desire 820(Android 5.0.2)
Build: Firefox for Android 44.0a1 (2015-10-21)

Steps to reproduce:
1. Go to http://mozilla.github.io/webrtc-landing/gum_test.html
2. Tap "Audio & Video"
3. Accept access to the device's built-in camera and built-in microphone

Expected results:
The video is playing from the built-in camera and sound is heard from the device speakers

Actual results:
Sound is heard from the device speakers, but the video from built-in camera is blank(not displayed)

Note:
good build: 28-06
bad build: 29-06

Enter pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d87b76177b2f5cf0839d73becebb614ab8a9ef7f&tochange=e45890951ce77c3df05575bd54072b9f300d77b0
>Build: Firefox for Android 44.0a1 (2015-10-21)

I presume that was a typo?
(Reporter)

Comment 2

2 years ago
Correct build is:

Tested with:
Device: HTC Desire 820(Android 5.0.2)
Build: Firefox for Android Nightly 50.0a1 (2016-06-29)
Any thoughts on what could have caused this (in that regression range)?
Component: General → Audio/Video
I looked at the pushlog but nothing stands out to me. There's JNI changes but they seem to be OK. Might need to bisect more precisely.
This works on all my devices (Nexus 4, Nexus 9, Motorola RAZRi). Snorp, does someone on your team have a more similar device?
Flags: needinfo?(snorp)
I found some other WebRTC regressions on Android (bug 1290075). Reporter, can you check whether after force-closing Fennec (via swiping it away in Task manager), and restarting, the problem goes away?
Flags: needinfo?(alex.caziuc)
(Reporter)

Comment 7

2 years ago
Hi Gian-Carlo,

Now Nithtly is 51, so I tried it on Aurora 50 with force-closing and restarting and it works(latest builds).
Flags: needinfo?(alex.caziuc)
So is this related to bug 1290075? It feels like force-closing and restarting isn't an acceptable workaround to ship but I'm not a decision-maker here :)
I think so. Not closing the camera correctly could cause it to end up in some state where we can not do new gUM requests. For me, refreshing the page and trying a new gUM request now consistently fails, though now that I've seen https://bugzilla.mozilla.org/show_bug.cgi?id=1290854#c5 I wonder if that's also related.
I refiled as bug 1292500 because one of the issues in the original bug turned out audio being broken.

I've seen similar behavior as in this bug, though in my case I couldn't start the gUM stream at all and got an error. There's clearly been regressions in the camera code...
Flags: needinfo?(snorp)
We've now tried this with a few people and we couldn't provoke any failures. Given that a restart made the device of the reporter work, I presume this is a very low frequency intermittent issue? Or do the steps in the description reproduce it fairly reliably on that specific device?
Flags: needinfo?(alex.caziuc)
(Reporter)

Comment 12

2 years ago
It seems that it's not reproducing anymore. So I'm closing this bug.

Verified using:
Device: HTC Desire 820(6.0.1) and Nexus 9(6.0.1)
Build: Firefox for Android Aurora-50(2016-08-05), Nightly-51(2016-08-05)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(alex.caziuc)
Resolution: --- → FIXED
Resolution: FIXED → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.