scaling page to one page, then printing still gives two pages

RESOLVED WORKSFORME

Status

()

Core
Print Preview
P5
normal
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: sujay, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
using 2/28 build of netscape

1) launch netscape
2) open a bug report in bugzilla
3) click on Format for Printing in report
4) clic on Print Preview
5) change scale to 54 or 53, to get it down to one page
6) Print

get output and notice that it is two pages...
expected: one page
(Reporter)

Updated

16 years ago
Keywords: nsbeta1

Comment 1

16 years ago
mine
Assignee: sgehani → rods

Comment 2

16 years ago
works for for me with yesterday's build on Win2k
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Priority: -- → P1
Resolution: --- → WORKSFORME
Summary: scaling page to one page, then printing still gives two pages → [WFM]scaling page to one page, then printing still gives two pages
Target Milestone: --- → Future
(Reporter)

Comment 3

16 years ago
REOPEN

Rod, you may me trying bug reports that are only one page long...then
you won't see the problem. Try it for bug report 99670 or any
bug report that is longer than a page... you will see the problem.

Once again, here are the steps:

1) launch netscape
2) open a bug report in bugzilla(chose one that is longer than one page)
3) click on Format for Printing in report
4) click on Print Preview
5) change scale to 54 or 53, to get it down to one page, or if the bug report
   is 3 pages long, try and get it down to 2 pages...you get the idea
6) Print

get output and notice it did not scale...you just get a printout of the
original number pages

reproduced with 3/6 trunk commercial build.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 4

16 years ago
I was using a different bug and was doing just that, and could not reproduce.

I can't get Bug 99670 to fit on 2 pages, I can't go below 50% to make that way.
I can make jump between 4 and 5 pages and I cannot reproduce the problem. This
isn't a bad problem compared to other bugs and does not deserve to be a nsbeta1.
Futuring as a P5, removing nsbeta1.
Status: REOPENED → ASSIGNED
Keywords: nsbeta1
Priority: P1 → P5
(Reporter)

Comment 5

16 years ago
so it is alright for a scaled down page in print preview to print
out 4 pages when you're only seeing 2 pages in print preview mode ?

(Reporter)

Updated

16 years ago
Summary: [WFM]scaling page to one page, then printing still gives two pages → scaling page to one page, then printing still gives two pages

Comment 6

15 years ago
*** Bug 203017 has been marked as a duplicate of this bug. ***

Comment 7

15 years ago
I had this problem too (wasted my last page of watermarked paper!) I used
custom: 95% scale.  Preview showed two pages, but second page was blank --
actual printout took one and a half pages even though preview did not show this.

Comment 8

14 years ago
*** Bug 186393 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
still a problem. Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051111 Firefox/1.6a1

set this bug to 55%, viewed at 1 page, printed at 2
Assignee: rods → printing
Status: ASSIGNED → NEW
QA Contact: sujay
Assignee: printing → nobody
QA Contact: printing

Comment 10

8 years ago
Created attachment 438435 [details] [diff] [review]
Patch proposed to correct bug #128351

This is a patch I made for one of our client who experienced this bug. The client reports that this patch fixes the issue.
I would appreciate any feedback/review.
Thx
Attachment #438435 - Flags: review?(neil)
Comment on attachment 438435 [details] [diff] [review]
Patch proposed to correct bug #128351

Sorry, but I was unable to reproduce this bug on Windows, and I don't have any other printing environment available to test this with.
Attachment #438435 - Flags: review?(neil)

Comment 12

8 years ago
Hello Neil,

Sorry: I should have added that this is a Thunderbird 2.0 bug only.

I have just reproduced it again on
- windows XP - thunderbird 2.0.0.24
- Linux Ubuntu Karmic Koala - thunderbird 2.0.0.19
- Linux Ubuntu Lucid Lynx - thunderbird 2.0.0.24 (even though Lucid Lynx comes with with TBird 3.0)

How I reproduce it :
1- launch TBird 2
2- select a long email
3- click "File/page settings", uncheck "Fit to page" and fill a size of say "50%"
(3a- click "File/print preview" -> pages are previewed at 50% which is what is expected)
4- click "File/print"

Result: email is printed full size 100%
Expected: email resized at 50%

Does it help?

Comment 13

8 years ago
(In reply to comment #12)
> Hello Neil,
> 
> Sorry: I should have added that this is a Thunderbird 2.0 bug only.

WFM then on current versions, and a patch wouldn't be accepted for v2. So closing.
Thanks Guillaume
Status: NEW → RESOLVED
Last Resolved: 16 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.