After reinstall from site I have 2 versions installed in different file system locations

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
2 years ago
7 months ago

People

(Reporter: levin.ashley, Unassigned, NeedInfo)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8766819 [details]
Firefox_two_versions.png

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36

Steps to reproduce:

After getting a black window when launching FF (I guess it was ver 45.02) I decided to reinstall FF from site. Result: I now have installed both versions: 45.02 and 47.01. First time this has happened to me since version 1.00


Actual results:

After reinstall from site I have 2 versions installed in different file system locations:
newer ver: C:\Program Files (x86)\Mozilla Firefox
older ver: C:\Program Files\Mozilla Firefox


Expected results:

FF should have removed the old version leaving me with one version only, as usual

Comment 1

2 years ago
Are they both 32 bits or 64 bits?
Flags: needinfo?(levin.ashley)
Hi,

I have tested this issue on Windows 8.1 x86 and could not reproduce it. I have installed version 45.0.2 (32 bits) first and  version 47.0.1 (32 bits) after. The old version(45.0.2) was removed and only last version installed(47.0.1) remains.

I have also tested on Windows 8 x64 and installed version 45.0.2 (64 bits) and version 47.0.1 (32 bits). Both Firefox versions are installed in different file system locations:
C:\Program Files (x86)\Mozilla Firefox -  FF  47.0.1 (32 bits)
C:\Program Files\Mozilla Firefox - FF 45.0.2 (64 bits)
Hi,

Marking this as Resolved:Invalid due to the fact that this bug is about installing Firefox 64 bits version and 32 bits version in different file system locations and this is an expected behaviour.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.