If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to delete, move, or modify most bookmarks

VERIFIED FIXED in mozilla1.0

Status

SeaMonkey
Bookmarks & History
P2
critical
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Waldemar Horwat, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
mozilla1.0
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2 rtm],custrtm-)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Recent (in the last three weeks or so) nightlies of Navigator now refuse to
delete, examine properties, or move many of my bookmarks in the Manage Bookmarks
window.  In general, this seems to affect older bookmarks (set a year or so ago)
but not more recently added bookmarks, but the correlation isn't entirely
consistent.

This is 100% reproducible, and consistent across runs of Navigator -- some
bookmarks can be manipulated while others cannot, and which ones are affected is
consistent from run to run.  I looked in the bookmarks.html file; it does not
appear to be corrupted and I cannot see any obvious difference between bookmarks
that work and adjacent bookmarks that don't.

The only thing I can do with an affected bookmark is double-click it to bring up
the page.  Trying to delete it, trying to rename it, or trying to move it has no
effect.  Trying to examine properties doesn't bring up the properties window. 
If I bring another window to the front while the Manage Bookmarks window has one
of the affected bookmarks selected and then bring the Manage Bookmarks window
back to the front, the File Bookmarks, Properties, Rename, and Delete
toolbuttons will be grayed out, even if I later select an unaffected bookmark.
(Reporter)

Comment 1

16 years ago
Created attachment 71990 [details]
Sample bookmarks.html file

OK; here's more information.  The problem occurs on any regular Netscape
bookmark I have that is the same as a bookmark in the "Imported IE Favorites"
list.  That's why it appears to occur only on older bookmarks -- IE had
imported Netscape bookmarks into its own list a while back.  In the sample,
cut-down file, the problem occurs on the "Skydive Hollister" bookmark, but not
on "The Mole" or "Googlewhacking", which I had added to Netscape's bookmarks
after IE grabbed its bookmarks from Netscape.

The problem goes away if I use a text editor to delete the line "<DT><A
HREF="NC:IEFavoritesRoot">Imported IE Favorites</A>" from the bookmarks.html
file, after which all bookmarks function correctly.  Will users be smart enough
to figure this one out?
(Reporter)

Updated

16 years ago
Keywords: nsbeta1
need to investigate/reproduce on mac. 

I may have a fix for this as a part of another bug. 
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla1.0

Comment 3

16 years ago
nsbeta1+ per Nav triage team
Keywords: nsbeta1 → nsbeta1+

Comment 4

16 years ago
>If I bring another window to the front while the Manage Bookmarks window has
>one of the affected bookmarks selected and then bring the Manage Bookmarks
>window back to the front, the File Bookmarks, Properties, Rename, and Delete
>toolbuttons will be grayed out, even if I later select an unaffected bookmark.

This issue is bug 121172.

Comment 5

16 years ago
*** Bug 130940 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
*** Bug 126863 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
Is this truly macos x bug, or was that just the default bugzilla value for the
person filing this -- no text so far in the bug to indicate which is the case.

Comment 8

16 years ago
I observed/reported this bug operating OS X.  Cannot speak to other 
platforms

Updated

16 years ago
OS: Mac System 9.x → All
Whiteboard: [adt2]

Comment 9

16 years ago
*** Bug 132014 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 132374 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
*** Bug 134522 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

16 years ago
In response to comment 7, I was using MacOS 9.2.2 when I filed this bug.

Comment 13

16 years ago
Isn't it anything to do with bug 133351?

Comment 14

16 years ago
This problem seems to happen consistently with bookmark folders that are
actually references to some file://.  If you try to move something into one of
these folders (e.g. file:///C|/WINNT/Profiles/jdyer/Favorites/Unix), it seems to
disappear.  Likewise, if you try to "File Bookmark" into one of these folders,
it gets dumped to the bottom of your bookmark list.

(I'm using the April 14, 2002 nightly build under Windows NT.)
OK, so I figured out what I said when I posted cryptically to this bug some
weeks ago. What I meant was that I was adding code that automatically removed
the old root (NC:IEFavoritesRoot or whatever it's called) when the new static
root is created. This code landed after this bug report was filed. This problem
would not manifest on windows because the dynamic IE root was never called
NC:IEFavoritesRoot, rather, it was the file:// URL of the favorites folder. 

I'm going to mark this bug as "FIXED" by my earlier changes that caused the
removal of the old root. Please reopen if you continue to see these problems in
recent builds. 
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 16

16 years ago
I'm not sure if what I am seeing is this bug, but if it is then it may not be
fixed or I need more information.

I d/l'd today's OSX trunk build (May 2) and I still cannot use 'File Bookmarks',
'Properties', 'Rename', or 'Delete' many, but not all, of my bookmarks. I see
the same thing in RC1 and later RC1 builds. 

If this is indeed fixed, how do I apply it to my current bookmarks?

Comment 17

16 years ago
Ben, is this fix already on the branch?

Updated

16 years ago
Whiteboard: [adt2] → [adt2 rtm]
Yes, the changes I refer to landed on the trunk long before 1.0 was branched.
Marking fixed1.0.0 to make that clear. 
Keywords: fixed1.0.0

Comment 19

16 years ago
As for comment #18

I am confused. It still cannot modify my bookmarks (I can delete or rename, but
I cannot move). I see you writing you filed it *before* branching. So why it
does not work on the trunk?

My build is: RH7.2 Build 2002050921 (trunk, but *certainly* after 1.0 branch)

Updated

16 years ago
Whiteboard: [adt2 rtm] → [adt2 rtm],custrtm-

Comment 20

16 years ago
  
build 2002051005

as per comment #1:

> The problem goes away if I use a text editor to delete the line "<DT><A
> HREF="NC:IEFavoritesRoot">Imported IE Favorites</A>" from the bookmarks.html
> file, after which all bookmarks function correctly.  Will users be smart enough
> to figure this one out?

this works, but it also deletes any bookmarks you've saved after this BM.  so if
you want to keep them, you need to open the IE Favorites folder in a new window,
and copy/paste each BM to a posistion above the referenced BM to delete.  then
quit so the BM file is saved.  then when you edit the bookmarks file in Word or
whetever, just delete everything from the "<DT><A>
HREF="NC:IEFavoritesRoot">Imported IE Favorites</A>" link on down...

all bookmarks seem to behave normally now.

Question:  why do we need both the "Properties..." and "Rename..." tab when they
both do the same thing?

dave
able to move, delete and modify bookmarks within bm mgr --tested with 2003.02.19
trunk bits on OS X.
Status: RESOLVED → VERIFIED

Comment 22

15 years ago
*** Bug 184966 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.