Closed Bug 1283638 Opened 4 years ago Closed 4 years ago

lack verification process for addon signatures in tree

Categories

(Testing :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1259528

People

(Reporter: kmoir, Unassigned)

References

Details

I didn't know what bucket to put this in so here it goes.  

We currently have a preference installed on beta that forces addons to be installed.  This means tests fail if the addon is not signed.  

However, this preference is not flipped on other branches. So the tests don't fail if the addon had an invalid signature, is not signed or some other permutation of breakage.   This means that on uplift from aurora to beta, any addons that were modified and not resigned correctly will cause failures.  We need to have an automated process that verifies that the addons that are signed in tree to avoid a scramble to fix test failures at every uplift. The current approach is very expensive.
Also, see bug 1281578
Duplicate of this bug: 1198371
Duplicate of this bug: 1233205
Duplicate of this bug: 1233204
:Ahal: is this a duplicate of bug 1259528 or are there other use cases that need to be addressed?
Flags: needinfo?(ahalberstadt)
Yeah, I think these two are dupes. Feel free to use whichever one you want, and if we use the other one I'll rename the reftest/mochitest to all test suites.
Flags: needinfo?(ahalberstadt)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1259528
You need to log in before you can comment on or make changes to this bug.