Intermittent dom/ipc/tests/test_child_docshell.html | Test timed out.

RESOLVED FIXED in Firefox 60

Status

()

RESOLVED FIXED
3 years ago
8 months ago

People

(Reporter: intermittent-bug-filer, Assigned: ochameau)

Tracking

({intermittent-failure})

unspecified
mozilla61
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox60 fixed, firefox61 fixed)

Details

(Whiteboard: [stockwell unknown])

Attachments

(1 attachment)

Comment 1

2 years ago
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Bulk priority update of open intermittent test failure bugs. 

P3 => P5

https://bugzilla.mozilla.org/show_bug.cgi?id=1381960
Priority: P3 → P5
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Duplicate of this bug: 1406593
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Alexandre, any idea what might be going on with this? Failing pretty regularly on trunk and beta right now.
Flags: needinfo?(poirot.alex)
(Assignee)

Comment 51

8 months ago
No idea, but here is a try with additional logs to see if DOMWindowCreated event is really not firing:
  https://treeherder.mozilla.org/#/jobs?repo=try&revision=2ba408d5a581c71cb5315728a5b9bb74c5b9d136
(Assignee)

Comment 52

8 months ago
(In reply to Alexandre Poirot [:ochameau] from comment #51)
> No idea, but here is a try with additional logs to see if DOMWindowCreated
> event is really not firing:
>  
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=2ba408d5a581c71cb5315728a5b9bb74c5b9d136

I'm not able to reproduce with additional logs.
So unless I don't run the right jobs (but it looks like it is failing on win10 opt, which I ran against), it looks like subtle race which isn't clear by just looking at the code.
Comment hidden (Intermittent Failures Robot)
It seems to more readily reproduce on PGO builds. In fact, I got this on a new Try push [1] with your patch applied:
https://treeherder.mozilla.org/logviewer.html#?job_id=174257156&repo=try

Does that help?

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=7218a2e3ce510f8b14712f455898627af6dea707
Comment hidden (Intermittent Failures Robot)
(Assignee)

Comment 56

8 months ago
Thanks Ryan!

Yes I think it helped me found this fix:
  https://treeherder.mozilla.org/#/jobs?repo=try&revision=29e2a8441347c2de6c5515d84fd7a106f8d7852f
Did I used the right try syntax?
Looks really promising!
Comment hidden (mozreview-request)

Comment 59

8 months ago
mozreview-review
Comment on attachment 8970561 [details]
Bug 1283714 - Wait for test document load in test_child_docshell.html to fix an intermittent.

https://reviewboard.mozilla.org/r/239318/#review245164
Attachment #8970561 - Flags: review?(bzbarsky) → review+
(Assignee)

Updated

8 months ago
Assignee: nobody → poirot.alex
Flags: needinfo?(poirot.alex)

Comment 60

8 months ago
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eb4c9a9c7320
Wait for test document load in test_child_docshell.html to fix an intermittent. r=bz

Comment 61

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/eb4c9a9c7320
Status: NEW → RESOLVED
Last Resolved: 8 months ago
status-firefox61: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
status-firefox60: --- → affected

Comment 62

8 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/fa5b3dea75ba
status-firefox60: affected → fixed
Flags: in-testsuite+
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.