Doing special chars inputs for the search on events webpage convert them into HTML entities

VERIFIED FIXED

Status

VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: clement.lefevre, Assigned: tasos)

Tracking

Details

(Whiteboard: [mozfr-community])

(Reporter)

Description

2 years ago
When using https://reps.mozilla.org/events/ and writing special chars in the search input, those chars are immediately converted into HTML entities, resulting in strange user experience
(Reporter)

Updated

2 years ago
Whiteboard: [mozfr-community]
Hey Tasos, can you take a look at this bug?
Flags: needinfo?(tasos)
(Assignee)

Comment 2

2 years ago
Thanks :flore for submitting this!
Assignee: nobody → tasos
Group: mozilla-reps-admins
Status: NEW → ASSIGNED
Flags: needinfo?(tasos)
(Assignee)

Comment 3

2 years ago
PR has been opened here:
https://github.com/mozilla/remo/pull/1212

Comment 4

2 years ago
Commits pushed to master at https://github.com/mozilla/remo

https://github.com/mozilla/remo/commit/38edc5dcdcf383b435b27771392160a1c277e9b6
[fix bug 1283814] Decode search url on events page.

https://github.com/mozilla/remo/commit/bd08903a7de1f9a36dd442fb7a3529d1c5607795
Merge pull request #1212 from akatsoulas/bug-1283814-decode-uri

[fix bug 1283814] Decode search url on events page.

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

2 years ago
Verified on stage that search is working properly for any input.
Status: RESOLVED → VERIFIED
Version: unspecified → next
(Assignee)

Updated

2 years ago
Version: next → 491
You need to log in before you can comment on or make changes to this bug.