Closed Bug 1284083 Opened 4 years ago Closed 4 years ago

Intermittent toolkit/components/places/tests/expiration/test_pref_maxpages.js | test_pref_maxpages - [test_pref_maxpages : 115] 0 == 1

Categories

(Toolkit :: Places, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- disabled
firefox54 --- disabled
firefox55 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: mak)

References

Details

(Keywords: intermittent-failure, Whiteboard: [fx-search])

Attachments

(1 file)

Duplicate of this bug: 1284121
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/9c7bde46a67a
Disable frequent intermittent toolkit/components/places/tests/expiration/test_pref_maxpages.js. r=test-disabled as suggested by mak on IRC
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Priority: P3 → P2
Whiteboard: [fx-search]
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/25fc050d41d8
Disable frequent intermittent toolkit/components/places/tests/expiration/test_pref_maxpages.js completely on Linux. r=test-disabled on a CLOSED TREE
https://hg.mozilla.org/mozilla-central/rev/9c7bde46a67a
https://hg.mozilla.org/mozilla-central/rev/25fc050d41d8
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Blocks: 1359607
I'll do some Try runs to ensure everything is fine.
ok, the fix works for test_pref_maxpages.js but it seems to cause a different intermittent in test_clearHistory.js, probably because that test is wrongly not using the PlacesTestUtils.clearHistory util (that properly waits for expiration to be finished)
The latest version of the patch looks good on Try!
Comment on attachment 8861945 [details]
Bug 1284083 - Fix a race condition in nsPlacesExpiration that may cause intermittent failures.

https://reviewboard.mozilla.org/r/133948/#review137488
Attachment #8861945 - Flags: review?(adw) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/c8fbd538c1ee
Fix a race condition in nsPlacesExpiration that may cause intermittent failures. r=adw
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Keywords: leave-open
Resolution: --- → FIXED
This is happening pretty frequently on Beta as well. Is it safe to uplift?
Flags: needinfo?(mak77)
I'd prefer the test to be disabled in beta, while it's not very unsafe, I'd still like this to ride the train.
Flags: needinfo?(mak77)
Whiteboard: [fx-search] → [fx-search][checkin-needed-esr52]
You need to log in before you can comment on or make changes to this bug.