Open Bug 1284119 Opened 3 years ago Updated 3 months ago

Intermittent test_places.py TestPlaces.test_plugins | ScriptTimeoutException: ScriptTimeoutException: Timed out

Categories

(Testing :: Firefox UI Tests, defect)

Version 3
defect
Not set

Tracking

(Not tracked)

REOPENED

People

(Reporter: intermittent-bug-filer, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: intermittent-failure, leave-open)

Here we seem to have a hang in remove_all_history():
https://dxr.mozilla.org/mozilla-central/source/testing/puppeteer/firefox/firefox_puppeteer/api/places.py#109

Our timeout is 10s. Marco, do you think that we should bump that up? I actually don't think so given that the number of history items is still low at this point.

15:35:48     INFO -   File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette/marionette_test.py", line 374, in run
15:35:48     INFO -     self.tearDown()
15:35:48     INFO -   File "/home/worker/workspace/build/tests/firefox-ui/tests/puppeteer/test_places.py", line 22, in tearDown
15:35:48     INFO -     self.places.remove_all_history()
15:35:48     INFO -   File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/firefox_puppeteer/api/places.py", line 117, in remove_all_history
15:35:48     INFO -     """, script_timeout=10000)
15:35:48     INFO -   File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 1633, in execute_async_script
15:35:48     INFO -     rv = self._send_message("executeAsyncScript", body, key="value")
15:35:48     INFO -   File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/decorators.py", line 38, in _
15:35:48     INFO -     return func(*args, **kwargs)
15:35:48     INFO -   File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 692, in _send_message
15:35:48     INFO -     self._handle_error(err)
15:35:48     INFO -   File "/home/worker/workspace/build/venv/local/lib/python2.7/site-packages/marionette_driver/marionette.py", line 725, in _handle_error
15:35:48     INFO -     raise errors.lookup(error)(message, stacktrace=stacktrace)
Flags: needinfo?(mak77)
(In reply to Henrik Skupin (:whimboo) from comment #1)
> Our timeout is 10s. Marco, do you think that we should bump that up? I
> actually don't think so given that the number of history items is still low
> at this point.

It should be a problem only with a quite large history or if you are removing History while there's an history view visible on the screen (the history sidebar or the Library in the history view).
Or maybe the disk is so busy on the box that it delays everything by seconds?

If you can reproduce such an hang locally, it may help, but off-hand I have no idea, it should really take more then a few ms if you have just a few history entries.
Flags: needinfo?(mak77)
Ok, I would say lets observe this test failure first before doing any action on it. It happened only once yet so no way to spend time on.
Actually the same cause as bug 1277935.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1277935
I filed bug 1289115 for fixing the underlying issue.
Status: RESOLVED → REOPENED
Depends on: 1289115
Resolution: DUPLICATE → ---
Status: REOPENED → RESOLVED
Closed: 3 years ago2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
You need to log in before you can comment on or make changes to this bug.