Nintendo of America's online store blocks Mozilla.

VERIFIED DUPLICATE of bug 117251

Status

--
major
VERIFIED DUPLICATE of bug 117251
17 years ago
4 years ago

People

(Reporter: macserv, Assigned: arun)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
PROBLEM DESCRIPTION ***
Nintendo's e-commerce site prevents access when using Mozilla.


STEPS TO REPRODUCE ***
0-) Download, install, and launch Mozilla.
1-) Open a Navigator window and attempt to access the above URL.
2-) Note the resulting page, which reads:

Netscape browser version 6 is not supported on the Nintendo Store at this time.
Please use a Netscape browser version 4 through 4.7, or Microsoft Internet
Explorer 3.0 or greater for best results.


EXPECTED RESULT ***
Should be able to order hardware, accessories, and parts from the site.


REGRESSION ***
No regression on Mozilla's part, but the site used to be reachable with Mozilla.
 I'm not convinced that this block is something they purposely implemented, but
rather may be a function of their servlet technology, which appears to be an IBM
JSP implementation, "WCS File Serving Servlet" is mentioned on error pages.


WORKAROUND ***
In conventional methodology, there is no workaround, however, through a bit of
hacking I've found that the following URL...

http://store.nintendo.com/webapp/wcs/stores/servlet/StoreCatalogDisplay?storeId=10001&catalogId=10001&langId=-1

...will allow you to bypass the browser check and enter the store, where it
appears Mozilla handles just fine.  No extensive testing done, but I was able to
complete and confirm a credit card purchase with no problem.


ADDITIONAL NOTES ***
Nintendo is making new accessories available on their e-commerce site before
they are available in stores.  These accessories are for their GameCube and
GameBoy Advance consoles, and are big sellers.  Because of this high demand for
Nintendo equipment via their website, I've set the severity of this bug to major.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 117251 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified
2002040303/WinXP
Status: RESOLVED → VERIFIED

Comment 3

16 years ago
tech evang june 2003 reorg
Component: US Ecommerce → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.