Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Save/Restore session, and xprop(1) -> _MOZILLA_URL(STRING) = "http://...

RESOLVED DUPLICATE of bug 36810

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 36810
16 years ago
13 years ago

People

(Reporter: stig hackvan, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla "ought" to be able to save & restore a session (maybe i want to shut
down a computer for reboot but not lose state, maybe it's just gone flaky and
slow, maybe i'm just enamored of checkpoint files, maybe I'm just sore cuz I
used to be able to do it with Netscape and now Mozilla lacks the feature that I
used...)


With Netscape, I used to harvest URLs from the X windows property tree.  when it
crashed i could just restart (losing forms data and login cookies, but hey...)

here's the shell script to do that the old way.  Adding the appropriate x window
property to mozilla windows would be EASY.  (so pretty please make it like
netscape)

doing checkpointing & save & restore The Right Way would be more work but also
more useful.  Reloading pages from local cache along with user-entered  but
unsubmitted form data (eg: textarea w/ half-composed reply to an email) in
progress would be profoundly slackful.  (You would be net.gods...  Bob would
surely reward you with a pipe like his.)

harvest-urls() {
  ps $pid >/dev/null || exit
  tmpfile=$ufile.p$$.r$RANDOM
  #
  # This script will find all the Netscrape Navigator windows on the screen
  # and make a list of all the URLS being accessed.  
  #
  perl -e '
    open (WINS, "xwininfo -tree -root |") or die;
    
    while (<WINS>) {
        next unless ( /": \("Navigator/ );
        
        m(^\s+(\S+) "Netscape: (.+)":) or next;
        print "$2\n";
        $props= `xprop -id $1`;
        $props =~ m(^_MOZILLA_URL.*= "(.*)"$)m;
        print "\t$1\n\n";
    }' > $tmpfile
  if [ -s $tmpfile ]; then
    if cmp  $tmpfile $ufile >/dev/null; then
      : files are the same so dont make another copy...
    else
      mv -b --backup=numbered $tmpfile $ufile
      rm -f `ls -t $ufile.* | tail +10` xyzzy$$ ;
    fi
  fi
  rm -f $tmpfile;
}

harvest-urls

Comment 1

16 years ago
Duplicate of "List current URL as an X property of the window"

*** This bug has been marked as a duplicate of 36925 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
i'm re-opening this feature enhancement bug because, although it contains
mention of a feature lost from netscape (Bug 128423 & Bug 64598), it suggests a
feature enhancement that can and should be considered for all versions of the
browser, regardless of platform.

mozilla bloats on unix, but windows crashes.  checkpoint files and the ability
to recover a lost session would make mozilla a much better browser.

-- stig
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
dup of 36810

*** This bug has been marked as a duplicate of 36810 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.