Remove MozContact API Android backend

RESOLVED FIXED in Firefox 51

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 51
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Firefox OS is gone.  But Firefox Android always initialize java code for MozContact Android backend.   We should remove it.
(Assignee)

Updated

2 years ago
Blocks: 942609
Yeah, I remember looking at this in the past (when FxOS still existed and we nevertheless wanted to remove this from Fennec). This bugs could be helpful: bug 1193431, bug 1240598.
Blocks: 1240598, 1193431
Comment hidden (mozreview-request)
Assignee: nobody → m_kato
Status: NEW → ASSIGNED

Comment 3

2 years ago
mozreview-review
Comment on attachment 8778772 [details]
Bug 1284283 - Remove MozContact API Android backend.

https://reviewboard.mozilla.org/r/69942/#review67102

LGTM.

- Did you already push this to try?

- The original patch in bug 1193431 removed some strings too (strings.xml.in, browser.properties). Can we remove them in this patch too or are they still needed?
Attachment #8778772 - Flags: review?(s.kaspari) → review+
Do you still want to push this over the finish line?
Flags: needinfo?(m_kato)
(Assignee)

Comment 5

2 years ago
(In reply to Sebastian Kaspari (:sebastian) from comment #3)
> Comment on attachment 8778772 [details]
> Bug 1284283 - Remove MozContact API Android backend.
> 
> https://reviewboard.mozilla.org/r/69942/#review67102
> 
> LGTM.
> 
> - Did you already push this to try?

Yes.  Also, we still turn off mozContact API on Android's mochitest because it doesn't work on our test infra.

> - The original patch in bug 1193431 removed some strings too
> (strings.xml.in, browser.properties). Can we remove them in this patch too
> or are they still needed?

Oh, OK, I will merge this removable.
Flags: needinfo?(m_kato)

Comment 6

2 years ago
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/mozilla-inbound/rev/181336fdda66
Remove MozContact API Android backend. r=sebastian

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/181336fdda66
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Duplicate of this bug: 1193431
You need to log in before you can comment on or make changes to this bug.