Java only works the first time when non-root

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
RESOLVED INVALID
16 years ago
7 years ago

People

(Reporter: Nikos Platis, Assigned: Joe Chou)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have never been able to make the Java plugin work when Mozilla is run by a
non-root user. On the contrary, as root the plugin always works well.

I have tried the plugin provided by Netscape (as root), as well as the plugins
provided by JRE 1.3.1 and JRE 1.4. The following report pertains to the latest
JRE 1.4. My system is running Mandrake 8.1 and I have tried several nightly
builds, all with the same results.

As root, I downloaded the latest JRE 1.4 from Sun and installed it in
/usr/lib/java/j2re1.4.0
Then in /usr/lib/mozilla/plugins I created a soft link to the plugin by
   ln -s /usr/lib/java/j2re1.4.0/plugin/i386/ns610/libjavaplugin_oji140.so
I started Mozilla (as a user) and visited http://java.sun.com, and both applets
on the page loaded successfully. However, when I closed Mozilla and re-run it,
visiting the same URL prompted me to install the Java plugin!
Tip: A quicker test to see if Java is working is to check the Tasks -> Tools ->
Java Console menu: if Java works, it is enabled, otherwise it is disabled.

I observe exactly the same behavior if I delete the link from the plugins
directory, run Mozilla once, then re-create the link: the first time I run
Mozilla Java is working, then it does not.

Running Mozilla as root Java works all the time.

Comment 1

16 years ago
oji.
Assignee: av → joe.chou
Component: Plug-ins → OJI
QA Contact: shrir → pmac

Comment 2

16 years ago
Never had this problem. I wonder if appreg is confused by several pointers to
various non.existant jre versions. Reporter: Please include build ID - and
here's something to try:

Move ~.mozilla out of the way (rename with a mv) and then start mozilla,
creating a fresh ~/.mozilla and profile for your regular user:
Does the problem still occur then?

Comment 3

16 years ago
Could this be due to directory or file permissions?
Please check your java installation (not only plugin lib!)
- e.g. try to tar your's /usr/lib/java/j2re1.4.0/ as non-root user.

(Reporter)

Comment 4

16 years ago
Creating a new profile, as suggested in Comment #2, worked! Now java works all
the time. Is there a way to correct this problem for my original profile? I
could provide my original configuration files for further investigation...

BTW, it was definitely not a matter of file permissions: regular users have read
permissions on all j2re1.4.0/ hierarchy.

Comment 5

16 years ago
Well, now you can try to copy (not move!) your original profile back and 
remove component.reg file there. Does this work?
(Reporter)

Comment 6

16 years ago
You probably meant ~/.mozilla/appreg (component.reg is only in the mozilla
installation directory). Yes, it works OK, thanks.

Comment 7

16 years ago
ok, OJI problem is resolved. I am gonna to close this is INVALID.

Probably it would be nice to make component.reg/appreg be more robust 
but i feel similar problem is already under investigation.

BTW, since 1.4 java plugin is supposed to be installed as component instead of
plugin (symlink must be made to components dir).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

16 years ago
I don't know if this behavior is reproducible, but it would probably be good to
add some notice about it in Release Notes, as well as the solution (i.e. delete
appreg so that it is re-created). I have seen, in Bugzilla and in newsgroups,
several complaints about Java not working correctly for non-root users, and it
may be the same problem as the one reported here.

Updated

16 years ago
QA Contact: pmac → petersen

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.