Crash in Abort | X_CopyArea: BadDrawable (invalid Pixmap or Window parameter); 4 requests ago | mozalloc_abort | NS_DebugBreak | X11Error

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: sammy, Assigned: acomminos)

Tracking

({regression})

47 Branch
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted], crash signature)

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-8426fd10-0687-4ddc-9399-94d6b2160627.
=============================================================

I'm running firefox from a remote server via ssh with X forwarding, to a Cendio Thinlinc X server, which is based on (Tiger) VNC. On startup firefox usually crashes 3-4 times in a row, and eventually starts up normally. I do not experience any problems after a succesful start.

I have tried 48.0b5, same problem.

When running firefox locally (not via ssh) the problem does not occur.

Updated

2 years ago
Component: General → Widget: Gtk
Product: Firefox → Core
Did this occur with Firefox 46?

Does changing gfx.xrender.enabled to true in about:config work around the issue?
(Reporter)

Comment 2

2 years ago
(In reply to Karl Tomlinson (back 18 July :karlt) from comment #1)
> Did this occur with Firefox 46?

No, Firefox 47 was the first version with this bug.

> 
> Does changing gfx.xrender.enabled to true in about:config work around the
> issue?

I will have to try that. I'll report back soon.
(Reporter)

Comment 3

2 years ago
Changing gfx.xrender.enabled to true seems to completely eliminate the
startup crashes. As a bonus, using my setup as described in the bug
description, Firefox seems much more responsive. Scrolling feels much
smoother. Playing video no longer blocks the user interface.
Blocks: 1241832
Component: Widget: Gtk → Graphics
Keywords: regression
status-firefox47: --- → affected
status-firefox48: --- → affected
Assignee: nobody → andrew
Whiteboard: [gfx-noted]
(Assignee)

Comment 4

2 years ago
Can you reproduce this issue on Nightly? We've made our remote X handling quite a bit more robust recently.
(Reporter)

Comment 5

2 years ago
With 50.0a1 the startup crash seems to be gone. Starting firefox over ssh a few times works, so this is by no means an exhaustive test. However, nightly feels much slower/very sluggish compared to 47 with xrender enabled. There is significant lag while scrolling. I tried opening a page containig video (youtube) to see if the user interface remained responsive, but the tab crashed after a few seconds.
(Assignee)

Comment 6

2 years ago
Thanks for checking! The slowdown is to be expected to some degree, as drawing and composition using XRender will be inherently faster over a network due to less raster transfers.

I'm going to close this as the crash itself is gone- bug 1281817 talks about potentially using XRender over remote X.
(Assignee)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
status-firefox47: affected → ---
status-firefox48: affected → ---
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.