hansenet.de - URL Redirection Limit exceeded

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
17 years ago
3 years ago

People

(Reporter: fsuehl, Assigned: tristan)

Tracking

({regression})

Details

(URL)

(Reporter)

Description

17 years ago
When trying to Log in into HanseNet's (www.hansenet.de -> MyHanseNet)
MyHanseNet, the browser refuses to load the page and displays an alert box that
says "Redirection limit for this URL exceeded. Unable to load the requested page". 
Netscape 6.2.1 has no problems with the page.
(Severity could have been "blocker", but I wasn't sure, for it could also be a
settings-problem)
-> Networking:Http
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
QA Contact: doronr → tever
The default limit is 10 redirects.  This page does more....  You could try setting:

user_pref("network.http.redirection-limit", 50);

and seeing whether that helps.

You could also try enabling all cookies and seeing whether _that_ helps...

Comment 3

17 years ago
It redirects in a loop.

http://w1.hansenet.de/hnet2001/1,1346,myhansenet_index,00.html
https://w1.hansenet.de/hnet2001/1,1346,myhansenet_index,00.html
/hnet2001/myhansenet/check_for_cookie/1,1503,myhansenet_index,00.html?cookie_name=my%5Fcookie
https://w1.hansenet.de/hnet2001/1,1346,myhansenet_index,00.html

Seems to be a problem on their end, not Mozilla's.

Comment 4

17 years ago
-> badami, yet another redirection limit reached bug.  looks like this one is a
regression from mozilla 0.9.4
Assignee: darin → badami
Keywords: regression

Comment 5

17 years ago
Lynx sees the same redirection loop so this is probably a site problem.

Comment 6

17 years ago
not mozilla problem. site problem
Assignee: badami → piskozub
Component: Networking: HTTP → Europe: Central
Product: Browser → Tech Evangelism
QA Contact: tever → pali
Version: other → unspecified

Comment 7

17 years ago
It's Germany. 
--> Europe:West.
Assignee: piskozub → nitot
Component: Europe: Central → Europe: West
QA Contact: pali → caillon

Comment 8

17 years ago
After todays patch, my mozilla (2002031108) does the same for ALOT of sites. All
cookies are accepted in my end.

One site that do this is http://google.com/

Actually most major sites has this problem since my upgrade 10 minutes ago.
Judging by the sites with problems, it could be a cookie thing.

Comment 9

17 years ago
Okay...think before you speak Jesper.

Flushed all cookies from Mozilla. Didn't help.

Then disabled cookie control in junkbuster. Didn't help.

Then flushed cache AND cookies from Mozilla, Junkbuster and Squid.

That helped.

So I guess it isn't REALLY a Mozilla problem - although I would like to know
what has changed since yesterday...

Comment 10

17 years ago
Confirmed
2002030908/WinXP
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Summary: URL Redirection Limit exceeded? → hansenet.de - URL Redirection Limit exceeded

Comment 11

17 years ago
*** Bug 133973 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
I'm also seeing this a few times today on www.nhl.com with RC1.
Build ID 2002041711.

Comment 13

17 years ago
This also happens with Mac OS X RC1 Build ID: 2002041712 on this URL:

<http://kbase.info.apple.com/cgi-bin/WebObjects/kbase.woa/wa/query?searchMode=Assisted&type=id&val=KC.106206>

The problem appears to be related to cookie settings.  Also, tried the above URL
with OmniWeb for Mac OS X and it loads up just fine.

More info:
It would appear that Mozilla is returning stale cookies.  After successfully
loading the page by clearing disk cache, clearing memory cache, deleting cookies
and cookie preferences for kbase.info.apple.com, the site finally loaded the
page.  However, I then once again deleted the cookies and cookie preferences for
kbase.info.apple.com and attempted to reload the page again with ask before
setting cookie chosen.  Mozilla then asked me if I wanted to accept another
cookie for kbase.info.apple.com saying I ALREADY HAD 2 COOKIES from that site?!

How could I still have two cookies?  I clicked "No" to the accept cookie and
checked the remember this decision box.  The page still loaded!!!  The only way
that page could have loaded is if Mozilla sent the stale cookies back to the server.

In Mozilla cookie preferences, there are still no cookies listed for
kbase.info.apple.com. And it lists kbase.info.apple.com as not being able to set
cookies.

Something is wrong with Mozilla's cookie management.

Comment 14

17 years ago
cc'ing morse

Comment 15

17 years ago
I see this bug when going to http://www.nytimes.com/2002/04/27/science/27GENO.html
but only if I have set my cookie preferences to
"Enable Cookies based on Privacy Settings" where the Privacy settings are
"Custom" and set to
Reject  Reject
Reject  Reject
Reject  Reject
Accept  Reject

If I change the cookie preference to "Enable cookies for the originating
website only" then I can successfully load the page (I already have a cookie
for nytimes.com having registered previously.)

Could this be an interaction between those privacy settings and the
way the site is set up? I can try playing with the privacy settings
to see if it makes a difference.

Comment 16

16 years ago
WFM? 2002062508 trunk win2k

Comment 17

16 years ago
Just to give some idea when this sort of thing happened, I was having the same
problem with most nytimes.com articles.  Looking in the cookie manager, I
discovered that I had 1 cookie for the site, but somehow had 'site cannot set
cookies' set.  Removing that allowed me to grab the second cookie that the site
needed.

Comment 18

16 years ago
Dup of bug 141702?

Comment 19

16 years ago
Bug 141702 looks like a duplicate of this.

Comment 20

16 years ago
received this message re: this bug via email:

> I have also encountered this problem. I am using version 1.2b on a Win2K sp3
> system, 512MB ram. If I restart Mozilla and go back to the same URL, I can
> get in no problem. I cannot get in until I restart though. The main page I
> have trouble with uses frames (http://www.rr.com/v5/frame/1,1863,42__tv,00
> html?url=tp://tvlistings1.zap2it.com/partners/editorial
> asp?partner_id=v). I hope this is helpful.
> 
> Kenneth Ellenburg

probably a different bug since it sounds like a browser problem whereas this bug
has been demonstrated to be a server bug.

Comment 21

16 years ago
WFM 2002112304 trunk win2k

Comment 22

16 years ago
This bug is reproducible at the following URL, when selecting any of the listed
platforms: http://h18007.www1.hp.com/support/files/

Mozilla 1.2.1
Windows XP SP1

The bug does not occur within IE 6SP1
Works for me build 2002122208
other examples given in comments also work for me.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
move...
Component: Europe: West → German

Comment 25

15 years ago
-v
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.