Closed Bug 1284431 Opened 6 years ago Closed 6 years ago

Make CDMProxy get rid of GMP specified types.

Categories

(Core :: Audio/Video: GMP, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1284192

People

(Reporter: JamesCheng, Unassigned)

References

Details

Once we finished Bug 1284192 the CDMProxy will be a base class,
but currently the CDMProxy has some types that indicated to GMPxxx e.g., |GMPCrashHelper|,  |GMPTimestamp|, |GMPSessionMessageType|, |GMPErr|.

We should find a elegant way to abstract CDMProxy from GMPxxx.
bug 1284192 is handled this bug.

mark as duplicate.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1284192
You need to log in before you can comment on or make changes to this bug.