Firefox is doing DNS lookup when I specify HTTP address with IP number

RESOLVED INVALID

Status

()

Core
Networking: HTTP
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Pascal Byrne, Unassigned)

Tracking

47 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.55 MB, application/zip
Details
(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

When I enter a URL using the private IP address for my local machine (http://192.168.50.41), Firefox tries to do DNS lookup for the address. This is adding a huge overhead to the page load. 

I am using a statically assigned IP address and DNS server. I am using the Google DNS servers: 8.8.8.8 and 4.4.4.4



Actual results:

The message 'Looking up 192.168.50.1' is displayed in the message bar accompanied by a long wait 



Expected results:

No DNS lookup.
(Reporter)

Comment 1

2 years ago
Page reload in Chrome: 1 second
Page reload in Firefox: 11 seconds
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
I'm not convinced the problem is trying to resolve a dotted decimal.. that might just be the last thing sent to the status bar.

Can you please reproduce your test case with logging enabled and add that log to this bug?

https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging
Flags: needinfo?(pbyrne76)
(Reporter)

Comment 3

2 years ago
Includes both the initial load of the page and then a reload
Flags: needinfo?(pbyrne76)
(Reporter)

Comment 4

2 years ago
Created attachment 8768317 [details]
log.zip
(Reporter)

Comment 5

2 years ago
After a little investigation, I find that it is security addons that are causing the slowdown. Apologies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.