Support WAI-ARIA in ToolSidebar component

RESOLVED DUPLICATE of bug 1286283

Status

()

Firefox
Developer Tools: Framework
P3
enhancement
RESOLVED DUPLICATE of bug 1286283
2 years ago
2 years ago

People

(Reporter: Honza, Unassigned)

Tracking

unspecified
Points:
---
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
This is follow up for bug 1259819

XUL sidebar has been replaced by HTML React component and we should make sure that the new implementation supports WAI-ARIA again (in XUL it's supported automatically).

Honza
(Reporter)

Updated

2 years ago
Whiteboard: [devtools-html]
Summary: Support WAI-ARIA in ToolSideber component → Support WAI-ARIA in ToolSidebar component
For the tabs, I wrote an article a while back: https://www.marcozehe.de/2013/02/02/advanced-aria-tip-1-tabs-in-web-apps/

The article uses lists and list items, but this can be applied analogously to whichever elements our new component uses.

For those elements that were xul:toolbar, putting role="toolbar" on the div that's the new container for those buttons should suffice.
Severity: normal → enhancement

Updated

2 years ago
Blocks: 1263741
Whiteboard: [devtools-html] → [devtools-html] [triage]

Updated

2 years ago
Flags: qe-verify-
Priority: -- → P3
Whiteboard: [devtools-html] [triage] → [reserve-html]
Closing since this is a dupe of bug 1286283, which was filed with feedback directly from Yura regarding the patch in bug 1259819. No need to have two bugs for the same thing. :-)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1286283

Updated

2 years ago
No longer blocks: 1263741
Whiteboard: [reserve-html]
You need to log in before you can comment on or make changes to this bug.