ServiceNow comments box behaves badly

RESOLVED WORKSFORME

Status

()

Firefox for Android
Toolbar
P2
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: snorp, Assigned: rbarker)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(firefox50 wontfix)

Details

Attachments

(1 obsolete attachment)

1) Go to a service now issue (in fennec)
2) Zoom into the comments/notes box
3) Focus the box and try to type something
3) Observer that you incorrectly get panned to the upper-left corner of the page
Assignee: nobody → rbarker
P2 because most users aren't going to use servicenow. If it happens on other websites we can bump up the priority.
Priority: -- → P2
(Assignee)

Comment 2

2 years ago
Created attachment 8771519 [details] [diff] [review]
0001-Prevent-overflow-hidden-frames-from-scrolling-16071513-2429a50.patch
Does this still occur? Are you working on it?
Flags: needinfo?(rbarker)
(Assignee)

Comment 4

2 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #3)
> Does this still occur? Are you working on it?

I'm not currently working on it. I assume it still happens although I tried to reproduce the issue to make sure and mozilla.service-now.com has updated again and the desktop version used to reproduce this issue either renders a blank page or is completely unusable in Fennec nightly. I guess I can try to create a simple iframe page with overflow:hidden to try and reproduce the problem.
Flags: needinfo?(rbarker)
(Assignee)

Updated

2 years ago
Attachment #8771519 - Attachment is obsolete: true
(Assignee)

Comment 5

2 years ago
To capture in the bug what I found while investigating the bug:

In Fennec with APZ enabled (now default), on pages where the body is set to overflow:hidden, if the page is zoomed in to a text edit in an iframe that is smaller than the text edit box, while typing into the text edit, when the text reaches the end of the text edit, Gecko attempts to scroll the text edit so that the cursor is still on the screen. Since Gecko does not know that APZ has scrolled the zoomed page, it scrolls the outer page to 0,0 which cases APZ to scroll the page to the top left corner rather than making the cursor visible.
(In reply to Randall Barker [:rbarker] from comment #4)
> I assume it still happens although I tried
> to reproduce the issue to make sure and mozilla.service-now.com has updated
> again and the desktop version used to reproduce this issue either renders a
> blank page or is completely unusable in Fennec nightly. I guess I can try to
> create a simple iframe page with overflow:hidden to try and reproduce the
> problem.

Ok, thanks. As is this bug is unactionable so I'm going to close it as WFM. Feel free to reopen once you have a testcase that reproduces the problem.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: affected → wontfix
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.