"Undo" drop down bar should be removed when a theme is uninstalled

RESOLVED DUPLICATE of bug 1298989

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 1298989
a year ago
a year ago

People

(Reporter: scolville, Assigned: aswan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [see github bug] triaged)

Attachments

(1 attachment)

Created attachment 8768075 [details]
Screen cast

Copied verbatim from: https://github.com/mozilla/addons-frontend/issues/697


Prerequisites:
Build identifier: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0

Steps to reproduce:
1.Follow instructions from https://wiki.mozilla.org/Add-ons/Projects/DiscoveryImprovements#Testing in order to set up the new disco pane on Nightly, AMO-dev
2.Install a new theme from about:addons (observe the "Undo" and "Manage Themes" drop down bar after a successful installation)
3.From on\off radio button, remove the theme

Expected results:
The "Undo" bar should be closed when a theme is uninstalled

Actual results:
"Undo" bar is still displayed.

Comment 1

a year ago
triaged - but real work updates will all happen in github bug
Whiteboard: [see github bug] triaged
(In reply to :shell escalante from comment #1)
> triaged - but real work updates will all happen in github bug

This probably does need work on FF as opposed to addons-frontend, since the bar is browser UI - unless there's already an API exposed. Ideally it would handle dismissal itself since the toolbar should know when a click outside it has been triggered.
Assignee: nobody → aswan
I would rather see bug 1286985 happen, if we can get that.

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1298989
Well not quite a duplicate, but fixing 1298989 will mean we don't have to worry about this one.
(In reply to Andy McKay [:andym] from comment #5)
> Well not quite a duplicate, but fixing 1298989 will mean we don't have to
> worry about this one.

Works for me! 
You need to log in before you can comment on or make changes to this bug.