Legal links from Mozilla Support page only go to English language versions

RESOLVED INVALID

Status

www.mozilla.org
Bedrock
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Casey McGill [NEED INFO ME], Unassigned)

Tracking

Development/Staging

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I noticed that if you set the Mozilla Support page to a localized site [1] and try to get to the legal notices in the footer ,the links only go to the English versions of the documents [2] and not their localized version [3]. 

[1] https://support.mozilla.org/fr/
[2] https://www.mozilla.org/en-US/privacy/websites/
[3] https://www.mozilla.org/fr/privacy/websites/
AFAIK, it's an expected behaviour not specific to the legal page. The linked URL is https://www.mozilla.org/privacy/websites/ (without a locale) so it gets redirected to the destination based on the user's browser locale. If you set French (fr) as your preferred language, you'll see the localized page.
Kohei is right; this is the intended behavior. The footer on support.mozilla.org doesn't presume any language for those off-site links. Upon arriving at www.mozilla.org, the page will automatically direct a user to the localized version according to their browser's language settings (assuming the page is available in that language). 

Thus if you're using an English browser you'll get the English privacy policy on www.mozilla.org, even if you came from a French page on support.mozilla.org. You would get the French version of the page using a French browser.

Also, some of our legal policies aren't translated at all and are only available in English, so depending on the page you request you may get English regardless of browser settings or what link you followed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

2 years ago
Thanks for the heads up, all I needed to know!
You need to log in before you can comment on or make changes to this bug.