Closed Bug 1284735 Opened 4 years ago Closed 4 years ago

Intermittent devtools/client/inspector/markup/test/browser_markup_dragdrop_autoscroll_02.js | Test timed out -

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(firefox50 fixed)

RESOLVED FIXED
Firefox 50
Tracking Status
firefox50 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: gregtatum)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 2 obsolete files)

Pretty frequent failures.
This test was added in bug 1226898 which landed 2 days ago.
Blocks: 1226898
Priority: -- → P2
This is one of the top failing intermittent devtools tests at the moment.
It has been failing frequently from the start, and only on Linux.

See also bug 1285106 where it does completes, but after the time threshold.

Greg: do you mind disabling this test on Linux until we figure out a better fix for it? I think we ought to stop the failures first, and then investigate a proper fix.
Flags: needinfo?(gtatum)
Here is the disabling patch. I'm looking into the issue right now.
Attachment #8772018 - Flags: review?(pbrosset)
Comment on attachment 8772018 [details] [diff] [review]
Disable intermittent test browser_markup_dragdrop_autoscroll_02.js

Review of attachment 8772018 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Could you please update it so it only skips on Linux, where it fails.
Also, in the future, test disabling patches don't really need to be reviewed. You can do:
Bug 1284735 - Disable intermittent test browser_markup_dragdrop_autoscroll_02.js r=me
or
Bug 1284735 - Disable intermittent test browser_markup_dragdrop_autoscroll_02.js r=test-only

::: devtools/client/inspector/markup/test/browser.ini
@@ +67,5 @@
>  [browser_markup_css_completion_style_attribute_02.js]
>  [browser_markup_css_completion_style_attribute_03.js]
>  [browser_markup_dragdrop_autoscroll_01.js]
>  [browser_markup_dragdrop_autoscroll_02.js]
> +skip-if = true # bug 1284735

As far as I could see on orange factor, this fails only on Linux. So this should be:
skip-if = os == "linux" # bug 1284735
Attachment #8772018 - Flags: review?(pbrosset) → review+
Ok, this only disables it on linux.
Attachment #8772025 - Flags: review+
Attachment #8772018 - Attachment is obsolete: true
Thanks! Let's ask for a checkin on this and keep the bug open to investigate a better solution.
The autoscroll tests weren't taking into account the scroll of the page when
it was sending the mousemove event. This should fix up the intermittents.
I'm still waiting on the try run. I'm wondering if I should kick off a
few for the linux debug build that was failing to make sure.

Also I shortened the number of divs on browser_markup_dragdrop_autoscroll_02.js test to make sure it finishes in a timely manner.
Flags: needinfo?(gtatum)
Attachment #8772067 - Flags: review?(pbrosset)
Comment on attachment 8772067 [details] [diff] [review]
Fix intermittents in browser_markup_dragdrop_autoscroll_02.js

Review of attachment 8772067 [details] [diff] [review]:
-----------------------------------------------------------------

The code changes look good, but we should really wait until you have a green try build with many re-triggers on linux.
I noticed that https://treeherder.mozilla.org/#/jobs?repo=try&revision=2e9292b0dd17 did not have any dt jobs. I've launched a bunch of new jobs, hope it will work (there was an email yesterday about jobs not being able to be retriggered, so not sure).
In any case, you can consider this a R+ for the code changes, but please wait until you're able to get a try build with green dt jobs on linux. What you should do is, once you get all of the dt jobs done, find the dtN buckets that contain the test browser_markup_dragdrop_autoscroll_02.js and retrigger those many times. I do this usually:
- click on the first dt1, click on the "raw logs" button at the bottom, search for browser_markup_dragdrop_autoscroll_02.js in the log,
- if it's not there, then go to dt2 and do the same, until you find the right dtN that actually ran your test,
- once found, press the "R" key like 10 times to retrigger that specific job 10 times,
- then do the same thing all over again for another linux build. Make sure you do this for at least e10s, non-e10s, debug and opt. Be careful, tests aren't always grouped in the same dt buckets depending on builds (just to make this more fun)!

I haven't found a more automated way to do this, but retriggering many test jobs on try is often the only way to know that an intermittent is fixed.
Attachment #8772067 - Flags: review?(pbrosset) → review+
do you want both patches checked in ?
Flags: needinfo?(pbrosset)
(In reply to Carsten Book [:Tomcat] from comment #19)
> do you want both patches checked in ?
When I set the flag, it was only for the first patch (attachment #8772025 [details] [diff] [review]).
But I've since then R+'d the second patch too, and I see in comment 17 that Greg has gotten a try build with a lot of retriggers that seem to show the problem is gone.
So I guess you can check in both patches now!
Thanks!
Flags: needinfo?(pbrosset)
Assignee: nobody → gtatum
Status: NEW → ASSIGNED
Comment on attachment 8772025 [details] [diff] [review]
Disable intermittent test browser_markup_dragdrop_autoscroll_02.js r=test-only

Per :pbro on IRC, this isn't needed anymore.
Attachment #8772025 - Attachment is obsolete: true
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/ead2d5b90435
Fix intermittents in browser_markup_dragdrop_autoscroll_02.js. r=pbro
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/ead2d5b90435
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.