Fix how Marionette is enabled on debug Fennec build (android-api-15-debug)

RESOLVED DUPLICATE of bug 1321408

Status

RESOLVED DUPLICATE of bug 1321408
2 years ago
8 months ago

People

(Reporter: maja_zf, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

From https://bugzilla.mozilla.org/show_bug.cgi?id=787203#c41: should "add an --enable-marionette flag to configure" ... "to play nice in a moz.configure world" (instead of ENABLE_MARIONETTE=1 in the in-tree mozconfigs)

See: https://hg.mozilla.org/mozilla-central/rev/88891cd76c27
(Reporter)

Comment 1

2 years ago
I poked around to see what this might be about. 'mobile/android/moz.configure' looks relevant...
Also tried to see how Marionette is enabled in any desktop builds, but didn't find anything promising so I'm not sure what the right solution is. 

gps, thanks for the feedback. When you get the chance, please tell me more.
Flags: needinfo?(gps)

Comment 2

2 years ago
References to "MARIONETTE" in old-configure.in should be ported to the Python moz.configure. See https://hg.mozilla.org/mozilla-central/rev/4b555450a4d8 for an example. This should encompass replacing the exporting of the MARIONETTE environment variable in mozconfigs with --enable-marionette. (We tend to avoid magic environment variables when possible.)
Flags: needinfo?(gps)

Updated

2 years ago
Component: Marionette → Build Config
Product: Testing → Core
(Reporter)

Comment 3

2 years ago
This sounds related to or a duplicate of Bug 1321408
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1321408

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.