Closed Bug 1284940 Opened 3 years ago Closed 3 years ago

Do we have more checkerboarding since 48?

Categories

(Core :: Panning and Zooming, defect, P2)

49 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox48 --- fixed
firefox49 --- fixed
firefox50 --- fixed

People

(Reporter: milan, Assigned: kats)

References

Details

(Keywords: regression, Whiteboard: [gfx-noted])

Attachments

(3 files)

Randomly on this page, but there are multiple examples, including bugzilla:

https://teslamotorsclub.com/tmc/threads/supercharger-bay-city-mi.69400/

Comparing Beta 48 (with E10S/APZ on) and Aurora 49 (the same)
This is retina Mac; will check if it happens on other platforms or hardware.  Tagging as regression to make sure we keep looking at this.
Keywords: regression
OS: Unspecified → Mac OS X
Summary: Do we have more checkerboarding? → Do we have more checkerboarding since 48?
Whiteboard: [gfx-noted]
Version: 38 Branch → Trunk
The paint times in the aurora log are 420ms and 730ms which are quite long. The longest paint time in the beta one is 296ms. But we don't know why the paint time is so long. Based on when this started appearing and that only people on retina mac devices have reported it, I suspect it might be the 100 tile limit that I put in bug 1262807 is too small.

Try build at https://treeherder.mozilla.org/#/jobs?repo=try&revision=c082092bcf07 makes that limit preffable, so we can increase it and see if it helps. (The build also makes it 1000 by default).
Much better with the patch.  The mystery now is, as I understand it, that we're not sure why things are better in Beta than in Aurora.

Are the paint times mentioned above that much larger for the same size of regions getting painted?  As in, painting slowed down?
It could be that painting slowed down, or it could be that we're invalidating more areas. Comparing what's happening with paintflashing enabled would probably allow distinguishing between the two scenarios.
P2 because it seems to only affect retina mac users so far.
Priority: -- → P2
Version: Trunk → 49 Branch
Attachment #8769758 - Flags: review?(mstange) → review+
Assignee: nobody → bugmail
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/76dbce2010b4
Increase the max number of tiles in a TiledRegion. r=mstange
https://hg.mozilla.org/mozilla-central/rev/76dbce2010b4
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Comment on attachment 8769758 [details]
Bug 1284940 - Increase the max number of tiles in a TiledRegion.

Approval Request Comment
[Feature/regressing bug #]: bug 1262807
[User impact if declined]: more checkerboarding in some configurations (so far only seen on a retina display on OS X)
[Describe test coverage new/current, TreeHerder]: not much automated test coverage; users who reported the increased checkerboarding say this helps
[Risks and why]: very low risk, just increasing a compile-time constant
[String/UUID change made/needed]: none
Attachment #8769758 - Flags: approval-mozilla-beta?
Attachment #8769758 - Flags: approval-mozilla-aurora?
Marking 48 as fix-optional because even though this extra checkerboarding wasn't seen on 48, the regressing patch is on 48 and so it's probably better to uplift this fix there as well.
Given this issue was not seen in 48 and it's late beta, mark won't fix in 48.
Comment on attachment 8769758 [details]
Bug 1284940 - Increase the max number of tiles in a TiledRegion.

Per comment #13, won't fix in 48.
Attachment #8769758 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
This only started happening on Beta 19 days ago, when bug 1262807 got uplifted to Beta. I think we should still uplift this. I'd hate to ship APZ in 48 with lots of checkerboarding on retina Macs.
Hi Milan,
Per comment #4, may I know if you have any feedback if this needs to be uplift to 48 beta?
^
Flags: needinfo?(milan)
Yes, I we would really want it on Beta.  Can't make the approval-mozilla-beta a ?, otherwise I would :)
Flags: needinfo?(milan)
Gerry, any chance you'll reconsider this for 48? ^
Flags: needinfo?(gchang)
Hi Kartikaya,
Let's take it in beta. Can you help to create the uplift request again? Thanks.
Flags: needinfo?(gchang) → needinfo?(bugmail)
I can't change the beta approval flag to any other value from the minus. It probably requires extra bugzilla permissions that I don't have. Can you just flip it back to a + directly? I don't have much new to add from the last uplift request.
Flags: needinfo?(bugmail) → needinfo?(gchang)
Comment on attachment 8769758 [details]
Bug 1284940 - Increase the max number of tiles in a TiledRegion.

This patch fixes a checkboarding issue. Take it in 48 beta 8 and aurora.
Flags: needinfo?(gchang)
Attachment #8769758 - Flags: approval-mozilla-beta-
Attachment #8769758 - Flags: approval-mozilla-beta+
Attachment #8769758 - Flags: approval-mozilla-aurora?
Attachment #8769758 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.