Closed Bug 1285021 Opened 6 years ago Closed 6 years ago

Synced objectURL tabs don't work

Categories

(Firefox :: Sync, defect)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
Firefox 50
Tracking Status
firefox50 --- fixed

People

(Reporter: tcsc, Unassigned)

Details

Attachments

(1 file)

The discussion in the meeting that lead to bug 1284669 made me realize that we try to do this, but it won't work. Very easy to repro, try https://jsfiddle.net/Lk506vw9/

Nothing bad happens, it's just a tab that never loads. We either shouldn't try to sync it at all, since it's specific to the browser it comes from, or we should convert it to a data url and sync that instead.
IIUC, the problem is that the blob: URL syncs correctly, it's just that it has no content when opened, right? If so, the simple answer is probably to just add a new pattern in https://dxr.mozilla.org/mozilla-central/source/services/sync/services-sync.js#33
Yes, exactly, and I can confirm making that fix solves the problem.
Comment on attachment 8768861 [details]
Bug 1285021 - Exclude urls starting with blob: from tab syncing

https://reviewboard.mozilla.org/r/62884/#review59878
Attachment #8768861 - Flags: review?(markh) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/74dd49dcf6c9
Exclude urls starting with blob: from tab syncing. r=markh
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/74dd49dcf6c9
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50
You need to log in before you can comment on or make changes to this bug.