Problem getting questions using the v2 API

UNCONFIRMED
Unassigned

Status

P3
normal
UNCONFIRMED
2 years ago
a year ago

People

(Reporter: acs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/51.0.2704.79 Chrome/51.0.2704.79 Safari/537.36

Steps to reproduce:

https://support.mozilla.org/api/2/question/?page=17624


Actual results:

Server error


Expected results:

Return a JSON with the questions in this page.

https://support.mozilla.org/api/2/question/?page=17623
https://support.mozilla.org/api/2/question/?page=17625

are working.
Hi Alvaro.

Can you still reproduce this issue? It works from my browser (tested from Fennec).
Component: Questions → General
(Reporter)

Comment 2

2 years ago
No, I can not reproduce it anymore!
Giorgos, can you investigate deeper in the logs?
Flags: needinfo?(acs) → needinfo?(giorgos)
Flags: needinfo?(giorgos)
(Reporter)

Comment 4

2 years ago
I am having issues more frequently now. For example:

https://support.mozilla.org/api/2/question/?ordering=updated&page=896

gives me an INTERNAL SERVER ERROR

Similar issues with other pager ...
Alvaro how do you use this data?
(Reporter)

Comment 6

2 years ago
We are working on creating metrics Dashboard for contribution on Mozilla.

In this case, we are using the perceval backend (not the final version yet):

https://github.com/acs/perceval/blob/kitsune/perceval/backends/kitsune.py

The idea is to get all questions and their answers in a first iteration and then update incrementally the data.

Updated

a year ago
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.