IMAP 'new folder' window layout incorrect first time

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Malcolm Scott, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.8+)
Gecko/20020227
BuildID:    2002022703

If 'Server supports folders that contain sub-folders and messages' is turned off
in 'Advanced IMAP Server Settings', the first time you open the 'New Folder'
window (File/New/Folder or right-click/New Folder), the layout is incorrect (the
OK and Cancel buttons are off the bottom of the window). The only way to close
the window is to press Enter/Esc on the keyboard.

Note that by 'first time', I mean that this bug occurs once at the start of each
Mozilla session; to see the bug again, you must completely close Mozilla, even
the Quick Launch component, then restart it.

Note also that this occurs in both Modern and Classic themes.

Reproducible: Always
Steps to Reproduce:
0. Close Mozilla completely, even the Quick Launch icon, and restart it.
1. Open Mail.
2. Edit / Mail & Newsgroup Account Settings; click 'Server Settings' under an
IMAP account; click 'Advanced'
3. Turn off 'Server supports folders that contain sub-folders and messages'.
Close dialog boxes.
4. Go to File / New / Folder

Actual Results:  The OK and Cancel buttons are invisible, as the window is too
small.

Expected Results:  The window should be made larger to accommodate these buttons
(as it is on subsequent appearances of that window).

I'll be attaching screenshots for both themes.
(Reporter)

Comment 1

17 years ago
Created attachment 72116 [details]
Screenshot of 'new folder' window (Modern theme)
(Reporter)

Comment 2

17 years ago
Created attachment 72117 [details]
Screenshot of 'new folder' window (Classic theme)

Updated

17 years ago
QA Contact: esther → huang
(Reporter)

Comment 3

17 years ago
Since the wording in that dialog has been changed, this problem appears to have
gone away. Could someone confirm this?

Comment 4

17 years ago
I've always wondered about this dialog - what happens if you change the folder
from/to a server whose folders don't support subfolders and messages?
(Reporter)

Comment 5

17 years ago
Aargh, oops. The problem appears to still be present (Linux 0.9.9). I don't know
why I sometimes see this, and sometimes not. It's certainly not just WinXP. I'll
see if I can reproduce it reliably.

With reference to comment 4, this does seem dodgy. I did a few experiments with
my setup (IMAP server which doesn't support folders with subfolders and
messages, and Local Folders which obviously does). If you have a folder on the
IMAP server selected, then go to File/New/Folder, the options "Folders
only"/"Messages only" are present whichever folder you choose to be parent. And
if you start with a Local Folder selected, then the options are never present,
plus all the IMAP folders are greyed out so you can't select them as parent.

Should this be filed as a separate bug?
OS: Windows XP → All

Comment 6

17 years ago
I've filed bug 131674 on that issue.
(Reporter)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

15 years ago
This dialog has been changed completely. Please re-submit this bug if you think
the problem still exists with the new New Folder window.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

15 years ago
Verifying WFM - this problem seems to have gone away.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.