Browser hangs when opening this page

RESOLVED DUPLICATE of bug 109604

Status

RESOLVED DUPLICATE of bug 109604
17 years ago
14 years ago

People

(Reporter: eilya497, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
See summary.

Comment 1

17 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020228
WFM.  page freezes Mozilla for a bit, but loads eventually.

Please ALWAYS include Build ID

Comment 2

17 years ago
on a day old CVS, Linux, 1024kbps/P3/500:
Mozilla freezes for around a minute, then renders "something" but the page looks
very wrong: images and menus repeat several times lower down the page, but are
missing where they probably are intended to display; closer to top.

Comment 3

17 years ago
Ah...  Well there are three issues:

1) the page (at the end of the html) assumes that any browser id'ing itself as
Netscape can handle layers.  That's why the page looks bad and non-functional.

2) hp_navScript.js seems to assume that navigator.appVersion.indexOf("MSIE")!=0
means that browser is IE (?why?). That doesn't help the functionality.

3) the performance hit during load is from document.writeln statements, which
are designed to create the menus.

if issue #1 was solved, #3 would not be so bad (not as much needs to be written
for IE menus)
(Reporter)

Comment 4

17 years ago
Sorry, build ID 2002020712
(Reporter)

Comment 5

17 years ago
indeed, it eventually opens, sorry.

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 109604 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.