mozilla/dom/MediaStreamTrackEvent.h not exported but unconditionally included

RESOLVED DUPLICATE of bug 1284726

Status

()

P2
normal
Rank:
25
RESOLVED DUPLICATE of bug 1284726
2 years ago
2 years ago

People

(Reporter: martin, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox50 affected)

Details

(Reporter)

Description

2 years ago
In my configuration the build fails (probably due to some missing/disabled configuration option) with :

In file included from /usr/pkgobj/wip/firefox-hg/work/build/dom/media/Unified_cpp_dom_media0.cpp:137:0:
/usr/pkgobj/wip/firefox-hg/work/mozilla/dom/media/DOMMediaStream.cpp:13:47: fatal error: mozilla/dom/MediaStreamTrackEvent.h: No such file or directory
compilation terminated.

source is:
#include "mozilla/dom/MediaStreamBinding.h"
#include "mozilla/dom/MediaStreamTrackEvent.h"
#include "mozilla/dom/LocalMediaStreamBinding.h"

but build/dist/include/mozilla/dom/ only has:

ls dist/include/mozilla/dom/*MediaStream*.h
dist/include/mozilla/dom/CanvasCaptureMediaStream.h
dist/include/mozilla/dom/CanvasCaptureMediaStreamBinding.h
dist/include/mozilla/dom/LocalMediaStreamBinding.h
dist/include/mozilla/dom/MediaStreamAudioDestinationNode.h
dist/include/mozilla/dom/MediaStreamAudioDestinationNodeBinding.h
dist/include/mozilla/dom/MediaStreamAudioSourceNode.h
dist/include/mozilla/dom/MediaStreamAudioSourceNodeBinding.h
dist/include/mozilla/dom/MediaStreamBinding.h
dist/include/mozilla/dom/MediaStreamError.h
dist/include/mozilla/dom/MediaStreamErrorBinding.h
dist/include/mozilla/dom/MediaStreamEvent.h
dist/include/mozilla/dom/MediaStreamEventBinding.h
dist/include/mozilla/dom/MediaStreamTrack.h
dist/include/mozilla/dom/MediaStreamTrackBinding.h

what moz.build magic is missing where?

Comment 1

2 years ago
https://dxr.mozilla.org/mozilla-central/rev/63cc31d6cc1c8089590461016ce0b4a2fb77ecbc/dom/webidl/moz.build#835 says due to missing WebRTC.

The bug appears to be either dom/media code including headers it shouldn't or dom/webidl/moz.build not generating interfaces when it needs to. Either way, bug component is DOM.
Component: Build Config → DOM
Product: Firefox → Core
Olli, do you know what generates this (see comment 1)?
Flags: needinfo?(bugs)

Comment 3

2 years ago
Isn't this a regression from bug 1181262 which for some reason put MediaStreamTrackEvent.webidl under webrtc ifdef, although that event isn't about webrtc but MediaStreams.
https://w3c.github.io/mediacapture-main/getusermedia.html#mediastreamtrackevent
Blocks: 1181262
Component: DOM → WebRTC
Flags: needinfo?(bugs) → needinfo?(martin.thomson)

Updated

2 years ago
Rank: 25
Priority: -- → P2
I'm traveling right now and for some reason gecko isn't building.  I have exhausted my time for working this problem out, or I would fix this.  If this is urgent, then removing guards on MediaStreamTrackEvent shouldn't take too much effort.
Looks like Jan-Ivar found and fixed the issue independently.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(martin.thomson)
Resolution: --- → DUPLICATE
Duplicate of bug: 1284726
You need to log in before you can comment on or make changes to this bug.