No mouse/pointer/touch events fired when scrolling an element on Windows touch

RESOLVED DUPLICATE of bug 1180706

Status

()

RESOLVED DUPLICATE of bug 1180706
2 years ago
2 years ago

People

(Reporter: joel.lear, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36

Steps to reproduce:

1. Go to a simple textarea (http://www.w3schools.com/tags/tryit.asp?filename=tryhtml_textarea)
2. Type enough text to get a scroll bar
3. Scroll using the touch screen


Actual results:

No events are fired that show that touch was used. Listened for mouse/pointer/touch events and none were fired when scrolling.


Expected results:

Events should fire when scrolling to indicate that the screen is being touched.

Updated

2 years ago
Blocks: 806805
Component: Untriaged → Widget: Win32
What browser version are you using? And can you copy the contents of your about:support and attach it to this bug?
Flags: needinfo?(joel.lear)
(Reporter)

Comment 2

2 years ago
Created attachment 8769198 [details]
about:support info
Ok, yeah - this is expected behaviour in Firefox 45. Current Windows nightly has touch events working, if you turn on e10s/APZ. I'm hoping to get it to release in Firefox 51 or 52. Marking this as a dupe of bug 1180706, which turned on touch events in Windows nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(joel.lear)
Resolution: --- → DUPLICATE
Duplicate of bug: 1180706
You need to log in before you can comment on or make changes to this bug.