Run test262 on every JS check-in

RESOLVED DUPLICATE of bug 977849

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 977849
2 years ago
a year ago

People

(Reporter: evilpie, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
We talked about this before, sadly we haven't done this yet.

I think integrating test262 tests into our existing test suite is going to take a lot of work that nobody wants to do. We should instead look into using their node.js runner and emitting something that treeherder/task cluster understands.

I hope we can find somebody to work on this. Sadly I don't understand Mozilla's CI infrastructure myself.

If nobody is interested in doing this I might just try to set up something hacky on digital ocean with cron jobs.
(Reporter)

Updated

2 years ago
Blocks: 652780
(Reporter)

Comment 1

2 years ago
We need to checkout a version of https://github.com/tc39/test262/ that we can easily update. We should use the nodejs runner from https://github.com/bterlson/test262-harness, but we probably need to do some modification into something taskcluster understands.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 977849
You need to log in before you can comment on or make changes to this bug.