Message body are not properly displayed when charset is ISO-2022-KR

RESOLVED DUPLICATE of bug 1176848

Status

MailNews Core
MIME
RESOLVED DUPLICATE of bug 1176848
2 years ago
2 years ago

People

(Reporter: Halton Green, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

2 years ago
Created attachment 8769030 [details]
sample message, just enough to reproduce the problem

User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.84 Safari/537.36

Steps to reproduce:

Open the message


Actual results:

Nothing displayed


Expected results:

Proper displayed message
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86
The message contains a syntax error.

> Content-Type: multipart/alternative; boundary="=_alternative 001CD40C49257FE6_="

multipart/alternative message should have close-delimiter at the end of the body, that is "--" + boundary + "--".
The message should end with "--=_alternative 001CD40C49257FE6_=--", but it ends with "--- ".

> --- 

What program generates the message?
Flags: needinfo?(halton)
(Reporter)

Comment 2

2 years ago
Created attachment 8769051 [details]
sample message, just enough to reproduce the problem - update
Attachment #8769030 - Attachment is obsolete: true
Flags: needinfo?(halton)
(Reporter)

Comment 3

2 years ago
(In reply to Tooru Fujisawa [:arai] from comment #1)
> The message contains a syntax error.
> 
> > Content-Type: multipart/alternative; boundary="=_alternative 001CD40C49257FE6_="
> 
> multipart/alternative message should have close-delimiter at the end of the
> body, that is "--" + boundary + "--".
> The message should end with "--=_alternative 001CD40C49257FE6_=--", but it
> ends with "--- ".
> 
> > --- 
> 
> What program generates the message?
 
The attachment is updated. The error occurred when I deleted unrelated part of the message.
thanks, the issue seems to be in the charset handling.
the message cannot be displayed with "ISO-2022-KR", but it can be when I change it to "UTF-8".
Status: UNCONFIRMED → NEW
Component: Message Reader UI → MIME
Ever confirmed: true
Product: Thunderbird → MailNews Core
Summary: Message body are not properly displayed → Message body are not properly displayed when charset is ISO-2022-KR
Version: 45 Branch → 45
seems to be a DUPE of bug 1176848.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1176848
(Reporter)

Comment 6

2 years ago
Thanks
You need to log in before you can comment on or make changes to this bug.