Attached images (.jpg) that are interrupted during download by switching messages are cached incomplete and don't display

VERIFIED DUPLICATE of bug 122491

Status

MailNews Core
Backend
--
major
VERIFIED DUPLICATE of bug 122491
17 years ago
10 years ago

People

(Reporter: esther, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Using build 20020227 on winxp IMAP if you get a message with an attached .jpg
image (large one so it takes time to load- 447kb)and you switch messages before
the image downloads completely the image is cached partially and selecting the
message again doesn't force another download, it displays the partial image.

1. Send youself a message with an attached jpg (447kb or bigger to insure you
have time to interrupt it).
2. Clear your memory and disk cache to make sure the image hasn't been cached
before. 
3. Get the message with the attachment, click on it and while it's downloading
before the image finishes loading click on another message.  
4. Click the message again and wait for the image to finish displaying.

Result: the image is cut off
Expected: the image to be complete
Note: Clicking on the message again doesn't help.  Only clearing the cache to
get a new download or sometimes receiving the exact image again in another mail
message that downloads compelely will fix the cached image.
(Reporter)

Comment 1

17 years ago
Note, I tried this with the Stop button instead of changing messages and that
has the problem too.
(Reporter)

Comment 2

17 years ago
dup of 122548, sorry for the confusion.

*** This bug has been marked as a duplicate of 122548 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
actually a dup of 122491
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 122491 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
yeah, dup it is.

verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.