After reformating a part of an email as "body test", typing at the end of this part will move the caret one line above.

RESOLVED DUPLICATE of bug 1281664

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 1281664
2 years ago
2 years ago

People

(Reporter: philipp.hessler, Unassigned)

Tracking

45 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

1. Open new Message Compose Window.
2. Type a few words (e.g. "Hello Peter,").
3. Hit enter twice.
4. Start a sentence (e.g. "This is a").
5. Mark all three lines and change the paragraph format to "body text" (was originally "paragraph").
6. Continue the sentence (e.g. " Test.").


Actual results:

After clicking at the end of the unfinished the sentence, the caret is positioned correctly. As soon as I start typing, the caret is moved to the line above and the resulting mail looks like this:

Hello Peter,
 Test.
This is a


Expected results:

The caret should not have moved and the mail should look like this:

Hello Peter,

This is a Test.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86
(Reporter)

Comment 1

2 years ago
This bug can still be reproduced in the nightly build of the 50 branch from 7th July 2016.

Comment 2

2 years ago
We know this problem, it has already been reported and analysed in bug 1281664.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1281664
You need to log in before you can comment on or make changes to this bug.