Status

()

Core
ImageLib
P3
normal
CLOSED INVALID
19 years ago
18 years ago

People

(Reporter: Richard Brunner, Assigned: pnunn)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Hi!

If I am starting mozilla-apprunner.sh the following error-message appears:
-------------
nsComponentManager: Load(/home/rbrunner/package/components/libnsjpg.so) FAILED
with error: libjpeg.so.62: cannot open shared object file: Datei oder
-------------
I think that I´ve the wrong version of libjpeg, that´s why some some pictures
were not be loaded, for instance http://www.orf.at !!?!
"rpm -qa | grep jpeg" says:
---------
jpeg-6a-74
libjpeg-6.0.1-74
---------

Which version do I have to use?
thank you
richard

System:
SuSE Linux 6.2 with Kernel 2.2.12
glibc 2.1
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 1

19 years ago
The jpeg version currently used is 6.2.
To find the version number:
 grep mozilla/configure.in MOZJPEG

You could:
  - Install the new jpeg lib from IJG (http://www.ijg.org)
  - Change the number in configure.in and rerun autoconf after a full clobber.
    (not recommended, but possible)
  - build the local mozilla jpeg directory. It is from the IJG source.

Make sure your links are set up properly in mozilla/dist/bin/ for the jpeg lib.

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 2

19 years ago
Glad Pam was able to help.

(Since this wasn't really a bug, I'm re-opening to Verify as Invalid.)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: FIXED → INVALID

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

18 years ago
I am using SuSE 6.3 (Kernel 2.2.13) and get a segmentation fault because of the
missing libjpeg. Installed libjpeg is 6.0.1 (I know: old version!). Since SuSE
Linux is a widespread distribution in Europe and elsewhere, I would consider to
change something, so that the SuSE users can test Mozilla as well as others.
Status: VERIFIED → REOPENED

Comment 4

18 years ago
Clearing INVALID resolution due to reopen.
Resolution: INVALID → ---
(Assignee)

Comment 5

18 years ago
Stephan:
the mozilla code base has a jpeg module included in the code base.
Check to make sure you are building it by looking at your autoconf
logs.
-P
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → INVALID

Comment 6

18 years ago
Rubber-stamping as verified/invalid.
Status: RESOLVED → CLOSED

Comment 7

18 years ago
*** Bug 26934 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.