Closed Bug 1285529 Opened 3 years ago Closed 3 years ago

B2G build broken: client.mk:114: *** missing separator. Stop.

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1278990

People

(Reporter: gerard-majax, Assigned: gerard-majax)

References

Details

Attachments

(2 files, 2 obsolete files)

Attached file content
Adding $(info MOZCONFIG_CONTENT=$(MOZCONFIG_CONTENT)) on line 114 gives this. I'm a bit worried about the part referring to errors.
Local revert of bug 1278990 and the issue is gone ...
Blocks: 1278990
I'm looking at my changes to mozconfig.cache now to see what could be causing this. Prime suspect, from an instinct perspective, is the wget call...
https://dxr.mozilla.org/mozilla-central/source/build/mozconfig.cache#49
Attachment #8769181 - Flags: review?(rthijssen) → review+
Comment on attachment 8769181 [details]
Bug 1285529 - Do not set SCCACHE when CCACHE_DIR is there

https://reviewboard.mozilla.org/r/63158/#review60018

win32,win64 still get their sccache config so lgtm.
Not good, it is still failing.
Comment on attachment 8769181 [details]
Bug 1285529 - Do not set SCCACHE when CCACHE_DIR is there

Review request updated; see interdiff: https://reviewboard.mozilla.org/r/63158/diff/1-2/
Attachment #8769181 - Attachment description: Bug 1285529 - Ensure wget failure do not break us → Bug 1285529 - Do not set SCCACHE when CCACHE_DIR is there
Comment on attachment 8769216 [details]
Bug 1285529 - Ensure wget failure do not break us

https://reviewboard.mozilla.org/r/63184/#review60026
Attachment #8769216 - Flags: review?(rthijssen) → review+
Attachment #8769216 - Attachment is obsolete: true
Attachment #8769217 - Attachment is obsolete: true
Attachment #8769217 - Flags: review?(lissyx+mozillians)
Pushed by alissy@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ae11e3061f5b
Do not set SCCACHE when CCACHE_DIR is there r=grenade
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/751186781016
Backed out changeset ae11e3061f5b to allow me to do a merge, relanding later
https://hg.mozilla.org/integration/autoland/rev/d5d91aa3a430
Do not set SCCACHE when CCACHE_DIR is there r=grenade CLOSED TREE
So, I backed this out to fix up a merge conflict that popped up when trying to merge m-c to autoland today.
I then did the merge and relanded this patch to autoland after the conflict was dealt with.

Then I realized that the conflict was caused by my backout from bug 1278990, and this patch's changes were only to the chunk of the file 1278990's patch added, so that whole chunk should be removed again.

Re-backed out in https://hg.mozilla.org/integration/autoland/rev/0215f0988f9c
Flags: needinfo?(lissyx+mozillians)
So I guess this patch should just be folded into the patch from bug 1278990's patch when it re-lands?
(In reply to Wes Kocher (:KWierso) from comment #16)
> So I guess this patch should just be folded into the patch from bug
> 1278990's patch when it re-lands?

Looking at the reasons of the backout, it is possible that this bug explicitely fixes this problem :/
Flags: needinfo?(lissyx+mozillians)
Marking as dupe since bug 1278990 will integrate those fixes.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1278990
You need to log in before you can comment on or make changes to this bug.