XMLHttpRequest.open() should not trigger onreadystatechange if readyState is already OPENED

RESOLVED DUPLICATE of bug 447689

Status

()

RESOLVED DUPLICATE of bug 447689
2 years ago
2 years ago

People

(Reporter: deckycoss, Assigned: deckycoss)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
according to the XHR spec, XMLHttpRequest.open() should only fire the readystatechange event if the state is not already OPENED (see step 12): https://xhr.spec.whatwg.org/#dom-xmlhttprequest-open

however, the open-open-send web-platform test shows that the open() method always triggers the event without accounting for the current state: https://hg.mozilla.org/mozilla-central/file/45682df2d2d4/testing/web-platform/meta/XMLHttpRequest/open-open-send.htm.ini

steps to reproduce:

./mach web-platform-tests testing/web-platform/tests/XMLHttpRequest/open-open-send.htm

Comment 1

2 years ago
Thanks for the report!

Work is currently being done to resolve this and other similar XHR issues (this one specifically is part of bug 447689).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447689
You need to log in before you can comment on or make changes to this bug.