[RR]{ib}inline-block inheritance breaks on restyle

RESOLVED DUPLICATE of bug 129350

Status

()

Core
DOM: CSS Object Model
RESOLVED DUPLICATE of bug 129350
16 years ago
16 years ago

People

(Reporter: Marc Loiselle, Assigned: dbaron)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Go to  http://www.wwf.com/news/rossreport/.  Only the first line "Greetings from
under the 200X black Resistol hat ..." of the report is displayed.  The text
uses the style storycaption_bk which is defined later in the html.  I will
attach the html shortly.

Buildid 2002022508.  Seeing this problem with Windows and linux.  

The page displays with Netscape 4.x and IE 6.
(Reporter)

Comment 1

16 years ago
Created attachment 72188 [details]
The html that has the problem
(Reporter)

Updated

16 years ago
Component: Style System → DOM Style
(Assignee)

Comment 2

16 years ago
This is either a parser problem or a ReResolveStyleContext problem.  This HTML
is also so ridiculously invalid that it's not high on my list.
Summary: Text is not displayed if style is not defined yet → [RR]Text is not displayed if style is not defined yet
(Reporter)

Comment 3

16 years ago
Created attachment 72191 [details]
Minimal testcase

This testcase makes it easier to see what is happening.  The body tag specifies
that text should be white.  Since the background is white the some of the text
does not display.  Interesting that "Visible" is shown but "Should be visible"
is not.
(Assignee)

Comment 4

16 years ago
Created attachment 72192 [details]
simple testcase

This is a problem with ReResolveStyleContext.  A ReResolve seems to be messing
up inline-block styles.
(Assignee)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [RR]Text is not displayed if style is not defined yet → [RR]inline-block inheritance breaks on restyle
(Assignee)

Updated

16 years ago
Summary: [RR]inline-block inheritance breaks on restyle → [RR]{ib}inline-block inheritance breaks on restyle
(Assignee)

Comment 5

16 years ago
The patch on bug 129350 fixes this.

*** This bug has been marked as a duplicate of 129350 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.