need to be able to set / get any attributes on nsAbCardProperties, not just the "standard" ones.

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
17 years ago
9 years ago

People

(Reporter: sspitzer, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 obsolete attachments)

SetCardValue() with generic column names needs to work properly on 
nsAbCardProperty, not just mdb card properties

cavin needs this for http://bugscape.mcom.com/show_bug.cgi?id=11575, and I 
think it would simplify some existing ab js / C++.
adding nsbeta1+, since the bugscape bug has that.
Status: NEW → ASSIGNED
Keywords: nsbeta1+
Target Milestone: --- → mozilla1.0
Created attachment 72240 [details] [diff] [review]
moz side of the fix, this time without hack changes to test the code
Attachment #72238 - Attachment is obsolete: true
hmm, I think this approach is flawed.  let me go back to the drawing board.
Attachment #72239 - Attachment is obsolete: true
Attachment #72240 - Attachment is obsolete: true
this approach has some flaws.  I'll meeting with cavin.  I think a cleaner fix 
can be made to nsAbSync.cpp alone.  invalid, I don't plan on making this work.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 7

17 years ago
Verified Invalid.
Status: RESOLVED → VERIFIED
reopening.

cavin and I have a fix going for bugscape bug #11575, but it could have been a
lot simpler if the addressbook wasn't such a mess.

here's some background:

there are abstract cards (ones that aren't in the db) and db cards.

we should be able to get / set properties on abstract cards, even if the
properties aren't the "well know" ones, like first name, last name, etc.

we need this for generic properties, like _AimScreenName

Then, we'd need to fix copycard() so that when copying a card, all values would
get copied into the db.

ugh, it's a big mess, and we're not going to get to it for 1.0

but one day, maybe.  let me just say that the addressbook architecture is a
giant mess.  dmose points out that is getting better, but it still hurts.

one day, we'll be able to make this kind of clean up
Status: VERIFIED → REOPENED
Keywords: nsbeta1+
Resolution: INVALID → ---
Summary: SetCardValue() with generic column names needs to work properly on nsAbCardProperty, not just mdb card properties → need to be able to set / get any attributes on nsAbCardProperties, not just the "standard" ones.
Target Milestone: mozilla1.0 → Future
when we get to this, we should also do this:

on nsIAbMDBCard, remove:

	wstring getStringAttribute(in string name);
	void setStringAttribute(in string name, in wstring value);

and instead just override these existing methods of nsIAbCard

	wstring getCardValue(in string name);
	void setCardValue(in string attrname, in wstring value);

this will require some code fixing in the ns tree, too.

wee!  I hate the addressbook.
Status: REOPENED → ASSIGNED
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
Status: ASSIGNED → NEW
QA Contact: nbaca → addressbook
Target Milestone: Future → ---

Comment 10

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 11

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.