The sync with my Apple calendar (read only mode) don't work.

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: st_hilaire.a, Unassigned)

Tracking

Lightning 4.7
x86_64
Windows 10

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

Thunderbird 45.2
Install sync function with my Apple calendar (read only mode)


Actual results:

Sync do not work


Expected results:

Blank page. A triangle appears beside the calendar name with an exclamation point. Message: The Calendar is temporarily unavailable. (This message appears since several days).
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 45 Branch → Lightning 4.7

Comment 1

2 years ago
Can you please elaborate what you mean with "install sync function with my Apple calendar" and provide detailed STR?
Flags: needinfo?(st_hilaire.a)
(Reporter)

Comment 2

2 years ago
(In reply to [:MakeMyDay] from comment #1)
> Can you please elaborate what you mean with "install sync function with my
> Apple calendar" and provide detailed STR?

My official calendar is on Apple icloud. I update my calendar with my iPad only because "Lightning" as plugin on my PC did not have a write sync with the Apple icloud server.

When I work on my PC (Win 10 64), I often need to read my calendar.

After the last "TB" update, I went on the Apple icloud site for generate a public url to share my calendar with this new update. After, I have created a calendar with this url on Thunderbird, but no sync. All was working fine with "Lighting" installed as a plugin ( TB Last version).

I tried to check everything in the calendar configuration, but I did not see the problem ...
Flags: needinfo?(st_hilaire.a)

Comment 3

2 years ago
Thanks for reporting back. What type of calendar do you have configured in Lightning - caldav or webdav/ics? Is offline support enabled? Do you see any error messages in the error console after TB startup or when triggering a synchrnization manually?
(Reporter)

Comment 4

2 years ago
(In reply to [:MakeMyDay] from comment #3)
> Thanks for reporting back. What type of calendar do you have configured in
> Lightning - caldav or webdav/ics? Is offline support enabled? Do you see any
> error messages in the error console after TB startup or when triggering a
> synchrnization manually?

I must say that my "Thunderbird" calendar is now synchronized !
I think the problem came from Apple.
My parameters were:
- iCalandar (ICS);
- Offline support enabled ;
- As commented in my first message: "A triangle appears beside the calendar name with an exclamation point. Message: The Calendar is temporarily unavailable. (This message appears since several days)."

Thank you for your support, and sorry for the problem who was not come from TB...

Comment 5

2 years ago
Thank you for confirming that it works again for you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.