Media Playback via Widevine Stutters, Jitters

RESOLVED DUPLICATE of bug 1266938

Status

()

Core
Audio/Video: Playback
P1
normal
RESOLVED DUPLICATE of bug 1266938
2 years ago
2 years ago

People

(Reporter: bryce, Assigned: bryce)

Tracking

(Blocks: 1 bug)

50 Branch
All
Windows
Points:
---

Firefox Tracking Flags

(firefox47 ?, firefox48 ?, firefox49 ?, firefox50 affected)

Details

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
Playback of encrypted media when using the Widevine CDM can result in a jittery or stuttery effect. Specifically it appears frames are being presented in an incorrect order. This can be seen when seeking in video, before the video 'catches up' after the seek there is a jitter in the frames presented. This seems to be worse in debug builds. I've noticed this particularly when debugging WebM, but am not certain it is a WebM specific issue -- I have also seen problems with mp4 h264 media.

In the worst case scenarios, that I believe I've only seen with WebM, play back get permanently stuck in a 'jittery' state.

This issue can be reproed using the Shaka player demo, with the Sintel Widevine media.
(Assignee)

Updated

2 years ago
Assignee: nobody → bvandyk
(Assignee)

Comment 1

2 years ago
Created attachment 8769505 [details]
MediaFormatReader NSPR_LOG output from Sintel Playback with Jitter
(Assignee)

Comment 2

2 years ago
Created attachment 8769508 [details]
Python script to parse MediaFormatReader logs and look for out of order samples
(Assignee)

Comment 3

2 years ago
Attached a log of Sintel playback that contains jitter near the end of playback. Also attached a python script to parse the logs and the look for out of order samples. Right now hard coded to load 'log.txt'. Running the script on the log created above suggests that the samples are being fed into the decoder in the correct order, but the samples returning form the decoded for video are out of order at times.
Priority: -- → P1
Blocks: 1222845
status-firefox47: --- → ?
status-firefox48: --- → ?
status-firefox49: --- → ?
OS: Windows 10 → Windows
Hardware: x86_64 → All
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1266938
(Assignee)

Comment 5

2 years ago
Resolving as a dupe, will continue working on this in the lower bug number.
You need to log in before you can comment on or make changes to this bug.