Temporary add-on not loaded in about:debugging

RESOLVED DUPLICATE of bug 1231128

Status

RESOLVED DUPLICATE of bug 1231128
2 years ago
6 months ago

People

(Reporter: gem, Unassigned)

Tracking

47 Branch
Unspecified
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

Followed the "Your first WebExtension" tutorial on MDN.

At the Testing It Out (https://developer.mozilla.org/en-US/Add-ons/WebExtensions/Your_first_WebExtension#Testing_it_out) stage, I followed the instructions to:
- open about:debugging
- click on the Load Temporary Add-On button
- select a file from the add-on's folder
- click Open


Actual results:

Dialog for choosing files was dismissed but the add-on wasn't loaded at all, no visual feedback at all, the list of add-ons remained the same.


Expected results:

Add-on should have been added to the list, and loaded into the browser.
(Reporter)

Updated

2 years ago
Component: Untriaged → Developer Tools: about:debugging
OS: Unspecified → Mac OS X
Hi Gem, thanks a lot for reporting this bug!

Maybe there was an error when you tried to load your temporary add-on in Firefox, but about:debugging didn't show it.

I see from your submission details that you're using Firefox 47. In Firefox 48, we fixed bug 1231128, which was preventing load-time errors from showing up. Could you please try reproducing the problem in a more recent version of Firefox, e.g. Nightly?

Andrew, is it possible that Gem's error would be caught and displayed in about:debugging now that bug 1231128 is fixed? In that case maybe we could close it as a duplicate.
Flags: needinfo?(aswan)
Yes, this sounds like exactly the scenario that bug 1231128 is meant to address.  Agreed that it is probably a duplicate, please try on 48 or newer.
Flags: needinfo?(aswan)
(Reporter)

Comment 3

2 years ago
Just tested on Nightly and it seems to be fixed. Thanks for looking at it though. Closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Updated

2 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1231128

Updated

6 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.