Closed Bug 1285883 Opened 4 years ago Closed 3 years ago

Facebook/YouTube videos often not starting.

Categories

(Core :: Audio/Video: Playback, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla52
Tracking Status
platform-rel --- ?
firefox50 --- verified
firefox51 --- verified
firefox52 --- verified

People

(Reporter: jya, Assigned: jya)

References

Details

(Whiteboard: [platform-rel-Facebook][platform-rel-Youtube])

Attachments

(2 files)

Attempting to play a video on Facebook often just never starts. It shows a spinning loading thing but nothing further happen.

This happens regardless of the connection type (100Mbit/s fibre or 6Mbit/s ADSL).

Like this video:
https://www.facebook.com/yonathan.gotlib/videos/10153590412486691/

with Chrome, the video always starts pretty much instantly.
Priority: -- → P1
and now that videos loads instantly :(

but I get this often with Nightly, either on my laptop or desktop.
See Also: → 1287079
Duplicate of this bug: 1287079
Assignee: nobody → jyavenard
Summary: Facebook videos often not starting. → Facebook/YouTube videos often not starting.
It doesn't start automatically on my Chrome. I have to click to start.
(In reply to JW Wang [:jwwang] from comment #3)
> It doesn't start automatically on my Chrome. I have to click to start.

yeah, but here clicking does nothing other than showing the loading spinner. You can see the video being buferred, but playback doesn't start.

I could reproduce it reliably on Saturday, but then I put the laptop to sleep and now it always work :(
I haven't had the problem in a while.. so assuming it's fixed for now. Will reopen as necessary
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
Has happened to me again today...

Video shows the first frame, we can see that video being entirely buffered, yet playback doesn't start.

I wonder what event facebook is waiting for that would cause playback to not start.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Yeah, I think I also saw this happen yesterday, it only worked after restarting Firefox.
(In reply to Jean-Yves Avenard [:jya] from comment #8)
> I wonder what event facebook is waiting for that would cause playback to not
> start.

What does about:media tell you? Is it in a playing state?
Need to get about:media working with e10s first :(
This problem is pretty reproducible for me on Facebook. At the time while seeing the spinner Firefox CPU usage goes to 200%. When I switch to another tab CPU usage drops to normal levels again.

about:media does not work for me in DE (because I have e10s on?).

I'm wondering if this is related to scrolling through the Facebook feed "too fast" and starting several video elements by doing that.
Didn't realize that about:media is a plugin I need to install. Here is a sample of it:

HTMLMediaElement debug data

https://www.facebook.com/
	https://scontent.fsnc1-1.fna.fbcdn.net/v/t43.1792-4/14416229_1748081495432072_426903575_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InN2ZV9oZCJ9&oh=72df0147e6f9b7d91127a83b6c370c6c&oe=57F43C6B
	currentTime: 0
	Quality: 100% (total:119 dropped:0 corrupted:0)
	Buffered ranges: [(0, 15)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 61
	audio state: ni=1 no=1 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:9 out:2 qs=7 pending:0 waiting:0 sid:4294967295
	video decoder: apple hardware VT decoder
	hardware video decoding: enabled
	video frames decoded: 77 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:17 out:11 qs=6 pending:0 waiting:0 sid:4294967295
	

	https://scontent.fsnc1-1.fna.fbcdn.net/v/t42.1790-29/14598754_604496793070516_9095457611448320000_n.mp4?efg=eyJybHIiOjQ1MCwicmxhIjo1MTIsInZlbmNvZGVfdGFnIjoic2RfZnJvbV9saXZlX2R2cl92MiJ9&rl=450&vabr=250&oh=bec17dc3799c0aadc9f65d87db7814a9&oe=57F4373C
	currentTime: 0
	Quality: 100% (total:102 dropped:0 corrupted:0)
	Buffered ranges: [(0, 102.387588)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 57
	audio state: ni=1 no=1 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:9 out:2 qs=7 pending:0 waiting:0 sid:4294967295
	video decoder: apple hardware VT decoder
	hardware video decoding: enabled
	video frames decoded: 66 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:17 out:11 qs=6 pending:0 waiting:0 sid:4294967295
	
https://www.heise.de/newsticker/
	https://dz6rzbt3lkau8.cloudfront.net/webm/115330132_581a3aa879.jom.4a6a9e9cbbc2c50d6787ac5c0913158a_360.webm
	currentTime: 0
	Quality: -- (total:0 dropped:0 corrupted:0)
	Buffered ranges: []
I'm also wondering if this is related to bug 1287668.
Same video playing properly:

HTMLMediaElement debug data

https://www.facebook.com/
	https://video.fsnc1-1.fna.fbcdn.net/v/t42.1790-2/14582857_104152606719839_8773991249351802880_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InN2ZTM2MF9xZl82NDB3X2NyZl8yMV9tYWluXzQuMl9wMTBfc2QifQ%3D%3D&oh=6919ffb552a48d8ad62b4cc9d93d4f12&oe=57F44A97
	currentTime: 0.986988
	Quality: 100% (total:48 dropped:0 corrupted:0)
	Buffered ranges: [(0, 120.053022)]
	Internal Data:
	audio decoder: unavailable
	audio frames decoded: 0
	video decoder: apple hardware VT decoder
	hardware video decoding: enabled
	video frames decoded: 42 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:48 out:42 qs=6 pending:0 waiting:0 sid:4294967295
	

	https://scontent.fsnc1-1.fna.fbcdn.net/v/t43.1792-4/14416229_1748081495432072_426903575_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InN2ZV9oZCJ9&oh=cd3f63b8c7b2c36e7af43b2e1c9175b5&oe=57F44A7B
	currentTime: 1.602187
	Quality: 100% (total:53 dropped:0 corrupted:0)
	Buffered ranges: [(0, 15)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 87
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:87 out:87 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: apple hardware VT decoder
	hardware video decoding: enabled
	video frames decoded: 47 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:53 out:47 qs=6 pending:0 waiting:0 sid:4294967295
	

	https://scontent.fsnc1-1.fna.fbcdn.net/v/t42.1790-29/14598754_604496793070516_9095457611448320000_n.mp4?efg=eyJybHIiOjQ1MCwicmxhIjo1MTIsInZlbmNvZGVfdGFnIjoic2RfZnJvbV9saXZlX2R2cl92MiJ9&rl=450&vabr=250&oh=bec17dc3799c0aadc9f65d87db7814a9&oe=57F4373C
	currentTime: 9.775604
	Quality: 100% (total:308 dropped:0 corrupted:0)
	Buffered ranges: [(0, 102.387588)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 279
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:279 out:279 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: apple hardware VT decoder
	hardware video decoding: enabled
	video frames decoded: 302 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:308 out:302 qs=6 pending:0 waiting:0 sid:4294967295
	
https://www.heise.de/newsticker/
	https://dz6rzbt3lkau8.cloudfront.net/webm/115330132_581a3aa879.jom.4a6a9e9cbbc2c50d6787ac5c0913158a_360.webm
	currentTime: 0
	Quality: -- (total:0 dropped:0 corrupted:0)
	Buffered ranges: []
Same video playing properly - after reloading the Facebook tab and scrolling down to the video which hang before.
"audio state: ni=1 no=1 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:9 out:2 qs=7 pending:0 waiting:0 sid:4294967295"

this is interesting...

in:9 while out:2...

With audio, qs should almost always be 0.
for video, a qs of 6 is to be expected with mac.

I don't believe the issue is with having too many HW decoders, as I'm seeing the problem on linux too which is all software decoding.

To test that this is true, could you try disable HW decoding by setting the pref media.hardware-video-decoding.enabled to false in about:config?

At least, we'll know for sure if the HW decoder is involved or not.

currentTime hadn't progressed in the first stalled video, yet both video and audio frames were decoded. Wonder if there's an event facebook is waiting on that we haven't fired.
So I set media.hardware-video-decoding.enabled to false. And restarted Firefox. The result was/is that I could scroll through a lot of videos on Facebook until I found one which hang. Here is the about:media dump when the video hang.


HTMLMediaElement debug data

https://www.facebook.com/
	https://scontent.xx.fbcdn.net/v/t43.1792-4/14530885_196295734126961_7132260689313267712_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InN2ZV9oZCJ9&oh=098f995ed18f65ff91155cc4eafe74b3&oe=57F55E2A
	currentTime: 1.776333
	Quality: 100% (total:66 dropped:0 corrupted:0)
	Buffered ranges: [(0, 122.889578)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 90
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 60 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	

	https://video.xx.fbcdn.net/v/t42.1790-2/13580246_1183509228337762_2114975616_n.mp4?efg=eyJybHIiOjg2NCwicmxhIjo3MTUsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=864&vabr=480&oh=fbce0e5fc39ed821fcb4dbef1c5f4572&oe=57F56F47
	currentTime: 1.787937
	Quality: 100% (total:58 dropped:0 corrupted:0)
	Buffered ranges: [(0, 79.16)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 90
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 52 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	

	https://video.xx.fbcdn.net/v/t42.1790-2/13832309_1823751504519403_1765193185_n.mp4?efg=eyJybHIiOjQ3NywicmxhIjo2NDUsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=477&vabr=265&oh=6a3dff83a2adb220fd3c88b5172b2ad2&oe=57F56FA1
	currentTime: 1.369979
	Quality: 100% (total:54 dropped:0 corrupted:0)
	Buffered ranges: [(0, 129.496163)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 80
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 48 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	

	https://scontent.xx.fbcdn.net/v/t43.1792-4/13954929_1734167176857829_1913420490_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InN2ZV9oZCJ9&oh=4fd9f3126e92a582d4cbb39804627747&oe=57F57649
	currentTime: 1.996937
	Quality: 100% (total:72 dropped:0 corrupted:0)
	Buffered ranges: [(0, 29.0624)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 95
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 66 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	

	https://video.xx.fbcdn.net/v/t42.1790-2/14607811_1464335520260216_1878263952446586880_n.mp4?efg=eyJybHIiOjM3MiwicmxhIjo1MTIsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=372&vabr=207&oh=272dbcae6a2256eb3650c583b7607c43&oe=57F56EC0
	currentTime: 2.449708
	Quality: 100% (total:75 dropped:0 corrupted:0)
	Buffered ranges: [(0, 15.08)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 106
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 69 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	

	https://video.xx.fbcdn.net/v/t42.1790-2/13789324_1308266289198677_1254605019_n.mp4?efg=eyJybHIiOjMzNiwicmxhIjo1MTIsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=336&vabr=187&oh=5d84222b2f4672e7a5829996e866ac23&oe=57F56D17
	currentTime: 4.95746
	Quality: 100% (total:161 dropped:0 corrupted:0)
	Buffered ranges: [(0, 48)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 151
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 155 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	

	https://scontent.xx.fbcdn.net/v/t43.1792-4/14450609_373013783087308_2403189194596810752_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InN2ZV9oZCJ9&oh=fd15b39125c53525eeb7a2cb7e0cc808&oe=57F56D20
	currentTime: 3.761645
	Quality: 100% (total:104 dropped:0 corrupted:0)
	Buffered ranges: [(0, 20.520511)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 136
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 98 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	

	https://video.xx.fbcdn.net/v/t42.1790-2/14602545_1746291905630549_4996525529214484480_n.mp4?efg=eyJybHIiOjM3MiwicmxhIjo1MTIsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=372&vabr=207&oh=1d40b0b2c7291fa4bf62af3ffbd7be22&oe=57F57099
	currentTime: 1.462875
	Quality: 100% (total:50 dropped:0 corrupted:0)
	Buffered ranges: [(0, 15.08)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 82
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 44 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	

	https://video.xx.fbcdn.net/v/t42.1790-2/14605936_702360619914883_2493513460638285824_n.mp4?efg=eyJybHIiOjQwMywicmxhIjo1NzcsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=403&vabr=224&oh=7395fecdce4699d9f5665a535e42b5a6&oe=57F5755A
	currentTime: 2.40327
	Quality: 100% (total:86 dropped:0 corrupted:0)
	Buffered ranges: [(0, 137.133334)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 105
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 80 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	

	https://video.xx.fbcdn.net/v/t42.1790-2/14596286_132370353892250_6528298612873494528_n.mp4?efg=eyJybHIiOjM5NiwicmxhIjo1MTIsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=396&vabr=220&oh=df70e5f761a78fbd0e1f6cc0566f70c0&oe=57F5712E
	currentTime: 0
	Quality: 100% (total:34 dropped:0 corrupted:0)
	Buffered ranges: [(0, 73.273273)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 50
	audio state: ni=1 no=1 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:16 out:3 qs=13 pending:0 waiting:0 sid:4294967295
	video decoder: apple software VT decoder
	hardware video decoding: disabled
	video frames decoded: 22 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:17 out:11 qs=6 pending:0 waiting:0 sid:4294967295
	

	https://scontent.xx.fbcdn.net/v/t43.1792-4/14530751_188257864934575_1319195494114656256_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InN2ZV9oZCJ9&oh=4a7c00282cd990dff859300ceebbd647&oe=57F5751C
	currentTime: 0
	Quality: 100% (total:7 dropped:0 corrupted:0)
	Buffered ranges: [(0, 4.2)]
	Internal Data:
	audio decoder: unavailable
	audio frames decoded: 0
	video decoder: apple software VT decoder
	hardware video decoding: disabled
	video frames decoded: 1 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:7 out:1 qs=6 pending:0 waiting:0 sid:4294967295
	
https://www.heise.de/newsticker/
	https://dz6rzbt3lkau8.cloudfront.net/webm/115330132_581a3aa879.jom.4a6a9e9cbbc2c50d6787ac5c0913158a_360.webm
	currentTime: 0
	Quality: -- (total:0 dropped:0 corrupted:0)
	Buffered ranges: []
This is how it looks like when it's hanging.

Just to be clear: there is currently no way for me to get these videos playing. I can click the pause icon. But once I click then the play button the video hangs exactly as before. The only workaround I'm aware of right now is to reload the whole page. Not sure if this is the same problem as the original report.
platform-rel: --- → ?
Whiteboard: [platform-rel-Facebook][platform-rel-Youtube]
Thanks for that. 

So we know it's not the hardware decoder. And once again we see tat the video that didn't start (the one with currentTime=0) are waiting on the audio decoder to return a sample. Which mac are you using?
I'm on a late 2013 15" MacBook Pro with macOS Sierra (although I think the problem existed also with El Captian already).
Here is another one. But this time the video actually plays for 0.5s or so and after turning on the sound I hear pretty garbled high pitched sounds until the player stops. The video appears to be fully fetched as I can see the preview over the time line for the full length of the video.

HTMLMediaElement debug data

https://www.facebook.com/
	https://scontent.fsnc1-1.fna.fbcdn.net/v/t43.1792-4/14439671_1075256282589195_2710650651888582656_n.mp4?efg=eyJ2ZW5jb2RlX3RhZyI6InN2ZV9oZCJ9&oh=5eed59e2883410ae3ad1d3cc219c2a89&oe=57F6DE6C
	currentTime: 0.859145
	Quality: 100% (total:52 dropped:0 corrupted:0)
	Buffered ranges: [(0, 223.181533)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 73
	audio state: ni=1 no=1 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:33 out:26 qs=7 pending:0 waiting:0 sid:4294967295
	video decoder: apple software VT decoder
	hardware video decoding: disabled
	video frames decoded: 40 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:35 out:29 qs=6 pending:0 waiting:0 sid:4294967295
	

	https://video.fsnc1-1.fna.fbcdn.net/v/t42.1790-2/14560849_1692988944354325_5404510631644626944_n.mp4?efg=eyJybHIiOjU3NCwicmxhIjo1MTIsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=574&vabr=319&oh=11f426425dfe3af0271261256c809738&oe=57F6E096
	currentTime: 1.001916
	Quality: 100% (total:424 dropped:0 corrupted:0)
	Buffered ranges: [(0, 48.50684)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 190
	audio state: ni=1 no=1 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:31 out:13 qs=18 pending:0 waiting:0 sid:4294967295
	video decoder: apple software VT decoder
	hardware video decoding: disabled
	video frames decoded: 352 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:37 out:31 qs=6 pending:0 waiting:0 sid:4294967295
	

	https://video.fsnc1-1.fna.fbcdn.net/v/t42.1790-2/14608966_345464889136820_338607009639170048_n.mp4?efg=eyJybHIiOjk0MywicmxhIjo1MTIsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=943&vabr=524&oh=51caa6a89184a40f2e4179fe4ad9d350&oe=57F6E516
	currentTime: 0
	Quality: 100% (total:34 dropped:0 corrupted:0)
	Buffered ranges: [(0, 47.922923)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 62
	audio state: ni=1 no=1 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:49 out:15 qs=34 pending:0 waiting:0 sid:4294967295
	video decoder: apple software VT decoder
	hardware video decoding: disabled
	video frames decoded: 22 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:17 out:11 qs=6 pending:0 waiting:0 sid:4294967295
	

	https://video.fsnc1-1.fna.fbcdn.net/v/t42.1790-2/14617432_1842292532673387_4863987889341464576_n.mp4?efg=eyJybHIiOjQwNSwicmxhIjo2OTcsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=405&vabr=225&oh=5d852800c3c8ce2974a01a343502005e&oe=57F6C9B7
	currentTime: 0
	Quality: 100% (total:17 dropped:0 corrupted:0)
	Buffered ranges: [(0, 165.065065)]
	Internal Data:
	audio decoder: shutdown
	audio frames decoded: 44
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	video decoder: shutdown
	hardware video decoding: disabled
	video frames decoded: 11 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:0 out:0 qs=0 pending:0 waiting:0 sid:4294967295
	
https://www.heise.de/newsticker/
	https://dz6rzbt3lkau8.cloudfront.net/webm/115330132_581a3aa879.jom.4a6a9e9cbbc2c50d6787ac5c0913158a_360.webm
	currentTime: 0
	Quality: -- (total:0 dropped:0 corrupted:0)
	Buffered ranges: []
I'm going to modify the about:media plugin to show if there's any errors attached to the element...
Once done, we will get more information if you're using nightly or dev edition.

So far, everything seems to point to an audio decoding issue...
I wonder if this is related to bug 1169552, which cpeterson says regressed when we changed how much decoded audio we need to cause us to advance the readyState? Can about:media also log the readyState? Would be handy if it can somehow know what events were fired, though that's more work I assume.
happened to me just then:
	https://video-syd1-1.xx.fbcdn.net/v/t43.1792-2/14512052_318555758499539_3178245794398470144_n.mp4?efg=eyJybHIiOjE1MDAsInJsYSI6MTAyNCwidmVuY29kZV90YWciOiJzdmVfaGQifQ%3D%3D&rl=1500&vabr=659&oh=1c3aae4e08b716d2a6c3f29d8cde5d0f&oe=57F6F826
	currentTime: 0
	Quality: 100% (total:24 dropped:0 corrupted:0)
	Buffered ranges: [(0, 46.316)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 8
	audio state: ni=1 no=1 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:22 out:7 qs=15 pending:0 waiting:0 sid:4294967295
	video decoder: apple software VT decoder
	hardware video decoding: disabled
	video frames decoded: 12 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:17 out:11 qs=6 pending:0 waiting:0 sid:4294967295


on nightly.

same deal here, with have for the audio: in:22 and out:7.. Which I don't see how it could ever happen with the mac audio decoder...
same deal with another:
	https://video-syd1-1.xx.fbcdn.net/v/t43.1792-2/14512052_318555758499539_3178245794398470144_n.mp4?efg=eyJybHIiOjE1MDAsInJsYSI6MTAyNCwidmVuY29kZV90YWciOiJzdmVfaGQifQ%3D%3D&rl=1500&vabr=659&oh=1c3aae4e08b716d2a6c3f29d8cde5d0f&oe=57F6F826
	currentTime: 0
	Quality: 100% (total:41 dropped:0 corrupted:0)
	Buffered ranges: [(0, 59.993333)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 8
	audio state: ni=1 no=1 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:22 out:7 qs=15 pending:0 waiting:0 sid:4294967295
	video decoder: apple software VT decoder
	hardware video decoding: disabled
	video frames decoded: 23 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:17 out:11 qs=6 pending:0 waiting:0 sid:4294967295


playback doesn't start, impossible scenario with in != out...

The only time I can think of where this could happen is it's HE-AAC and the SBR is in-band. The mac decoder needs to scan the stream until it finds the SBR to start... It could then drop the frame until it finds the first one playable.

But those are typically in the first sample...

Maybe there's something wrong there..
currentTime: 0 readyState: 4 error: 3 (0x806e0004: SubmitSample: Unable to decode sample 489025)

this is after a change that limit how many frames we'll look into to detect if it's HE-AAC (as used by facebook)
Comment on attachment 8798711 [details]
Bug 1285883: Limit how many frames we will parse to detect HE-AAC.

https://reviewboard.mozilla.org/r/84140/#review83628
Attachment #8798711 - Flags: review?(dglastonbury) → review+
Pushed by jyavenard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e312817dd3dc
Limit how many frames we will parse to detect HE-AAC. r=kamidphish
https://hg.mozilla.org/mozilla-central/rev/e312817dd3dc
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Any chances you could try a build with the change and see if that works any better for you?

thanks
Flags: needinfo?(drno)
As there is no known reproducible test case I just scrolled threw my Facebook timeline for 5 times as much as I normally do and video played instantly, paused and started playing again.
So yeah looks like its fixed! Thanks a lot.
Flags: needinfo?(drno)
Comment on attachment 8798711 [details]
Bug 1285883: Limit how many frames we will parse to detect HE-AAC.

Approval Request Comment
[Feature/regressing bug #]: Mac AAC decoder
[User impact if declined]: facebook vidéos not starting. Facebook is a pretty popular site!
[Describe test coverage new/current, TreeHerder]: in central, manual test
[Risks and why]: very low. We just limit how much try to detect an HE-AAC stream. In the worse case, the HE-AAC stream isn't found and the lower quality AAC-LC one is played instead.
[String/UUID change made/needed]: none
Attachment #8798711 - Flags: approval-mozilla-beta?
Attachment #8798711 - Flags: approval-mozilla-aurora?
Comment on attachment 8798711 [details]
Bug 1285883: Limit how many frames we will parse to detect HE-AAC.

Stabilized on Nightly for a few days, bug filer has verified the fix on a try build, Aurora51+, Beta50+
Attachment #8798711 - Flags: approval-mozilla-beta?
Attachment #8798711 - Flags: approval-mozilla-beta+
Attachment #8798711 - Flags: approval-mozilla-aurora?
Attachment #8798711 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
hmmmm... still happening here. entering the conditions as shown there:
https://www.facebook.com/
	https://video-syd1-1.xx.fbcdn.net/v/t42.1790-2/14667127_1048687028582769_6376883801460572160_n.mp4?efg=eyJybHIiOjg3MSwicmxhIjo1MTIsInZlbmNvZGVfdGFnIjoidjNfNDI2X2NyZl8yM19tYWluXzMuMF9zZCJ9&rl=871&vabr=484&oh=89d5cab2ab7e44a1ec35e67b207d349f&oe=5805A409
	currentTime: 0 readyState: 4
	Quality: 100% (total:7 dropped:0 corrupted:0)
	Buffered ranges: [(0, 8.24449)]
	Internal Data:
	audio decoder: apple CoreMedia decoder
	audio frames decoded: 1
	audio state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:3 out:1 qs=2 pending:0 waiting:0 sid:4294967295
	video decoder: apple software VT decoder
	hardware video decoding: disabled
	video frames decoded: 1 (skipped:0)
	video state: ni=0 no=0 ie=0 demuxr:0 demuxq:0 tt:-1.000000 tths:-1 in:7 out:1 qs=6 pending:0 waiting:0 sid:4294967295


hit the conditions for every videos here (in=3 out=1)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
ah ... I think it's because I had opened firefox in 32 bits mode and is likely bug 1308418
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
See Also: → 1311876
I was not able to reproduce this issue on desktop or laptop using STR from comment 0. I will mark this verified fixed, because I get playback every time I open the video provided by Jean-Yves. 

The test were performed on 50.0 (20161101104304), 51.0a2 (2016-11-04) and 52.0a1 (2016-11-04) under Windows 10 x64 (pc and laptop), Ubuntu 16.04 x64 and macOS 10.12.1.
If you have any questions please let me know.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.