Closed Bug 12859 Opened 21 years ago Closed 20 years ago

nsRenderingContextGTK - State transitions need to reuse regions

Categories

(Core Graveyard :: GFX, defect, P3, major)

x86
Linux

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ramiro, Assigned: pavlov)

Details

nsRenderingContextGTK - State transitions need to reuse regions.

The problem is the gtk rendering cx allocates a region for each state
transition, unlike windows which reuses regions.

This causes the UI to be slugish, for example mousing over toolbar buttons in
the apprunner.
reassign to pavlov@netscape.com
Assignee: ramiro → pavlov
I fixed this a few months ago
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Marking verified fixed per last comments.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.